Bug 799323 - Initial 'emptyarchive' page contains hostname rather urlhost in listinfo page link
Initial 'emptyarchive' page contains hostname rather urlhost in listinfo page...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: mailman (Show other bugs)
6.2
All All
medium Severity high
: rc
: ---
Assigned To: Jan Kaluža
qe-baseos-daemons
: Patch
Depends On:
Blocks: 727267
  Show dependency treegraph
 
Reported: 2012-03-02 08:47 EST by Robert Scheck
Modified: 2012-11-20 08:43 EST (History)
6 users (show)

See Also:
Fixed In Version: mailman-2.1.12-18.el6
Doc Type: Bug Fix
Doc Text:
Cause: urlhost argument was not handled in newlist script Consequence: links on archive page was not created with proper URLs. Hostname was used instead. Fix: urlhost is now handled in newlist script. Result: If urlhost is provided, it's used instead of hostname on archive page.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 08:43:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mailman-2.1.12-newlist-urlhost.patch (4.33 KB, patch)
2012-03-02 09:13 EST, Robert Scheck
no flags Details | Diff

  None (edit)
Description Robert Scheck 2012-03-02 08:47:02 EST
Description of problem:
Because of the processing sequence in bin/newlist and Mailman/Cgi/create.py,
the initial archive index page for a new list is built with a link to the listinfo page with host name DEFAULT_URL_HOST (hostname(1)) instead of the
host name supplied to newlist with -u (urlhost).

Version-Release number of selected component (if applicable):
mailman-2.1.12-17.el6.x86_64

How reproducible:
Everytime, eg. "/usr/lib/mailman/bin/newlist --urlhost=foo.bar mailman". The
result in the index.html is whatever hostname(1) returns, if no defaults are
changed in the configuration.

Actual results:
Initial 'emptyarchive' page contains hostname rather urlhost in listinfo page
link.

Expected results:
Initial 'emptyarchive' page contains urlhost listinfo page link if specified;
if not then DEFAULT_URL_HOST/hostname(1) content is used.
Comment 1 Robert Scheck 2012-03-02 09:12:24 EST
I cross-filed case 00609370 in the Red Hat customer portal for this issue.
Comment 2 Robert Scheck 2012-03-02 09:13:18 EST
Created attachment 567073 [details]
mailman-2.1.12-newlist-urlhost.patch

The attached patch solves this issue for us, please apply.
Comment 4 Jan Kaluža 2012-03-05 05:20:02 EST
Thanks for the patch. I've tested it and it fixes the bug you described.
Comment 6 Robert Scheck 2012-03-05 05:44:08 EST
I know, it's a patch from upstream - that is slightly adapted for 2.1.12.
Comment 15 Jan Kaluža 2012-07-31 06:46:34 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: urlhost argument was not handled in newlist script

Consequence: links on archive page was not created with proper URLs. Hostname was used instead.

Fix: urlhost is now handled in newlist script.

Result: If urlhost is provided, it's used instead of hostname on archive page.
Comment 18 errata-xmlrpc 2012-11-20 08:43:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1474.html

Note You need to log in before you can comment on or make changes to this bug.