Bug 799333 - After every reboot of the node (2.2.3-1.1) the ssh keys change
After every reboot of the node (2.2.3-1.1) the ssh keys change
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Fabian Deutsch
:
Depends On:
Blocks: 805540
  Show dependency treegraph
 
Reported: 2012-03-02 09:08 EST by Michel van Horssen
Modified: 2016-04-26 22:18 EDT (History)
7 users (show)

See Also:
Fixed In Version: 2.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 16:10:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel van Horssen 2012-03-02 09:08:55 EST
Description of problem:

After rebooting the node I wanted to login via ssh again and got a key change warning. After removing the key for this host from known_hosts and accepting the new keys I rebooted the node again to see if the keys would change again and they did.

Mentioning this in IRC yossarianuk noticed the same problem

Version-Release number of selected component (if applicable):

2.2.3-1.1

How reproducible:


Steps to Reproduce:
1. ssh in to the node as admin and accept the key (if its the first time)
2. In the tui menu tell the node to reboot
3. ssh in to the node as admin again, you get a key change warning.
Comment 1 Fabian Deutsch 2012-03-19 09:13:26 EDT
It seems as if the ssh host keys weren't persisted because of a missing back slash.

http://gerrit.ovirt.org/#change,2931
Comment 2 Fabian Deutsch 2012-03-21 06:46:49 EDT
The following patch also fixes this bug for the standalone case:

http://gerrit.ovirt.org/#change,2981

(The previous patch was abandoned)

Note You need to log in before you can comment on or make changes to this bug.