Bug 799351 - System reports (pdf format) does not show first 2 columns info
System reports (pdf format) does not show first 2 columns info
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity high (vote)
: Unspecified
: --
Assigned To: Tomas Strachota
Katello QA List
: Triaged
Depends On:
Blocks: 703617 katello-blockers
  Show dependency treegraph
 
Reported: 2012-03-02 09:59 EST by Garik Khachikyan
Modified: 2015-01-04 16:59 EST (History)
5 users (show)

See Also:
Fixed In Version: katello-0.2.12-1, katello-cli-0.2.11-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 20:31:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sample report (6.45 KB, application/pdf)
2012-03-02 09:59 EST, Garik Khachikyan
no flags Details
name and uuid are now visible in the report (6.01 KB, application/pdf)
2012-03-19 05:27 EDT, Kedar Bidarkar
no flags Details

  None (edit)
Description Garik Khachikyan 2012-03-02 09:59:00 EST
Created attachment 567083 [details]
sample report

Description of problem:
Recent version of CFSE does not generate information of first two columns (name,uuid) in the pdf formatted report of systems.

Version-Release number of selected component (if applicable):
Current CFSE latest

How reproducible:
always

Steps to Reproduce:
1.make registration of at least one system
2.on CLIL: `system report --org ACME_Corporation --format pdf`
3.open the katello_systems_report.pdf (note first 2 columns are empty)
  
Actual results:
empty / no info about name, uuid

Expected results:
listed first two columns info there. 

Additional info:
attached is a simple report
Comment 2 Tomas Strachota 2012-03-07 09:30:24 EST
I don't know what is the cause but dashes in the name break the output. I'm doing some more investigation.
Comment 3 Tomas Strachota 2012-03-13 09:58:39 EDT
This bug was caused by pdf-writer used by Ruport library. It tries to guess correct column widths. It sometimes fails and then columns with zero width are not displayed. This can be prevented by setting fixed column width in options for pdf report.

Fixed in katello-0.2.12-1, katello-cli-0.2.11-1
Comment 5 Garik Khachikyan 2012-03-15 04:26:39 EDT
@Jordan,

Sorry but if you really verified the bug, please put here a comment.

I'm moving bug back to ON_QA.
Comment 6 Kedar Bidarkar 2012-03-19 05:26:25 EDT
[root@scalpel ~]# rpm -qav | grep -i katello 
katello-glue-candlepin-0.1.304-1.el6.noarch
katello-configure-0.1.104-1.el6.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-pulp-0.1.304-1.el6.noarch
katello-selinux-0.1.8-1.el6.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
katello-common-0.1.304-1.el6.noarch
katello-0.1.304-1.el6.noarch
katello-all-0.1.304-1.el6.noarch
katello-cli-0.1.105-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-0.1.104-1.el6.noarch
katello-glue-foreman-0.1.304-1.el6.noarch
katello-certs-tools-1.0.4-1.el6.noarch
Comment 7 Kedar Bidarkar 2012-03-19 05:27:38 EDT
Created attachment 571069 [details]
name and uuid are now visible in the report

name and uuid are now visible in the report

Note You need to log in before you can comment on or make changes to this bug.