Bug 799480 - Polkit always asks for the password of the first user in wheel
Polkit always asks for the password of the first user in wheel
Status: CLOSED DUPLICATE of bug 771278
Product: Fedora
Classification: Fedora
Component: polkit (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 12:42 EST by Sergio Pascual
Modified: 2013-03-05 23:08 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-02 14:17:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sergio Pascual 2012-03-02 12:42:45 EST
Description of problem:

When required authentication, polkit asks for the password of the first user in the wheel group. If you are in the wheel group, but you are not the first user, polkit will ask you for the password of this user even if you are in wheel.

Polkit should ask you your password if your user is in wheel.


I have checked that this command asks for my password:

pkcheck --action-id org.opensuse.cupspkhelper.mechanism.devices-get \
         --process $$ -u

If I edit /etc/group and put another user in group wheel before me, then the command asks me for the password of that user instead of mine.
Comment 1 David Zeuthen 2012-03-02 14:17:52 EST
See bug 771278 comment 3.

*** This bug has been marked as a duplicate of bug 771278 ***

Note You need to log in before you can comment on or make changes to this bug.