Bug 799500 - Internationalization yum-presto
Internationalization yum-presto
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-presto (Show other bugs)
16
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Jonathan Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 14:45 EST by dominique
Modified: 2012-04-11 23:20 EDT (History)
8 users (show)

See Also:
Fixed In Version: yum-presto-0.7.3-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-11 23:20:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum-presto-0.7.1-2.fc16.src.rpm (31.00 KB, application/x-rpm)
2012-03-02 14:45 EST, dominique
no flags Details
yum-presto-0.7.1-2.fc16.noarch.rpm (32.29 KB, application/x-rpm)
2012-03-02 14:46 EST, dominique
no flags Details
yum-presto-0.7.1-3.fc16.noarch.rpm (32.29 KB, application/x-rpm)
2012-03-09 14:13 EST, dominique
no flags Details
yum-presto-0.7.1-3.fc16.src.rpm (32.23 KB, application/x-rpm)
2012-03-09 14:13 EST, dominique
no flags Details
yum-presto-0.7.1-2.test.fc16.src.rpm (33.36 KB, application/x-rpm)
2012-03-17 12:46 EDT, dominique
no flags Details

  None (edit)
Description dominique 2012-03-02 14:45:15 EST
Created attachment 567151 [details]
yum-presto-0.7.1-2.fc16.src.rpm

I use yum-presto, but it's not internationalized yet...

For me, I build this version internationalized, if you want, you can use and may be integrate in official repo for fedora.

Dominique
Comment 1 dominique 2012-03-02 14:46:33 EST
Created attachment 567152 [details]
yum-presto-0.7.1-2.fc16.noarch.rpm
Comment 2 dominique 2012-03-02 14:49:49 EST
i precise in this rpm there is the french translation, validated by the transifex french team  which I belong
Comment 3 Kevin Raymond 2012-03-03 15:47:56 EST
Thank you dominique, that would be great that the yum team includes your patch and add yum-presto to the yum project under transifex.net.

IMHO, all plugins enabled by default under Fedora should have translations (there is no point to have only part of yum translated).
Comment 4 dominique 2012-03-09 14:11:34 EST
Code cleanup, see attachments yum-presto-0.7.1-3.fc16.noarch.rpm and yum-presto-0.7.1-3.fc16.src.rpm.

If the maintainer of yum-presto could answer me...
Comment 5 dominique 2012-03-09 14:13:04 EST
Created attachment 568985 [details]
yum-presto-0.7.1-3.fc16.noarch.rpm
Comment 6 dominique 2012-03-09 14:13:44 EST
Created attachment 568986 [details]
yum-presto-0.7.1-3.fc16.src.rpm
Comment 7 Jonathan Dieter 2012-03-09 14:34:50 EST
I have seen this and will review your changes ASAP. Unfortunately, I'm currently very busy with $dayjob, but I hope to have some time in the coming week.
Comment 8 Jonathan Dieter 2012-03-15 03:46:32 EDT
First off, a huge thank you for working towards internationalizing yum-presto!  I really appreciate the effort as I know nothing about internationalization.

I would love to incorporate your patch, but there are a few problems that need to be fixed first:

1. I'm not sure why you converted setup.py to a Makefile, but I would like to stick with setup.py and extend it to copy the necessary files to the necessary locations.

2. I'm not sure what the purpose is in creating /var/lib/up2date, but, if it's not being used, I don't believe there's any reason to create it.

For what it's worth, yum-presto's git repository is available at git://git.fedorahosted.org/git/hosted/presto.  If you could send me git patches rather than a full src.rpm, it would make it easier to see what's changed, and, thus, easier to review.

Once again, thanks for your effort on this!
Comment 9 dominique 2012-03-15 13:24:29 EDT
Thank for your reply.

I want to clarify a few things:

-- First I am not a programmer and I made this internationalization from package yum-rhn-plugin, and adapt to yum-presto.

In this package there is a line in the spec (in %files): %dir /var/lib/up2date but for yum-presto it's not used and you can remove this line (I forgot it when I clean code).

I use a makefile because I am not a programmer, and I don't know how made internationalization with python, I just adapt the yum-rhn-plugin to yum-presto.

There is an how-to for that here : http://docs.python.org/library/gettext.html
but for me it's very hard...
Comment 10 dominique 2012-03-17 12:45:51 EDT
Hi all...

I found this how-to : http://wiki.maemo.org/How_to_Internationalize_python_apps

After multiple tests, I can build an rpm with apparently translation.

But that don't work, when I launch Yum I have this error:

"Plugin "presto" can't be imported"

I don't know why...

I attach the source rpm "yum-presto-0.7.1-2.test.fc16.src.rpm", If you can see what it's wrong...
Comment 11 dominique 2012-03-17 12:46:41 EDT
Created attachment 570813 [details]
yum-presto-0.7.1-2.test.fc16.src.rpm
Comment 12 Jonathan Dieter 2012-03-20 07:41:22 EDT
I'll take a look at this as soon as I have time.
Comment 13 Fedora Update System 2012-03-26 07:15:49 EDT
yum-presto-0.7.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-presto-0.7.2-1.fc17
Comment 14 Jonathan Dieter 2012-03-26 07:17:12 EDT
I'm pushing an update for Fedora 17, but as this is an enhancement and not a bugfix, I'd prefer not to update Fedora 16.
Comment 15 Kevin Raymond 2012-03-26 08:44:42 EDT
Thank you, works for me (using French locale).
Could you now add the POT in our translation plateform transifex.net?

You could see with the yum team if you want to reuse there translations team, or the one of the Fedora Project.

https://www.transifex.net/projects/p/yum/

http://help.transifex.net/#getting-started

You would probably prefer a new ticket for that… I help you if you want.

Cheers,
Comment 16 dominique 2012-03-26 15:13:44 EDT
Thank you Jonathan, I rebuild your rpm source for F16, and that work fine.

I think you can close this "bug"...
Comment 17 Fedora Update System 2012-03-28 01:55:21 EDT
Package yum-presto-0.7.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-presto-0.7.2-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-4767/yum-presto-0.7.2-1.fc17
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2012-03-29 12:58:48 EDT
yum-presto-0.7.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-presto-0.7.3-1.fc17
Comment 19 Fedora Update System 2012-04-11 23:20:39 EDT
yum-presto-0.7.3-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.