Bug 799507 - SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the None bootcd.iso.
SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the None boot...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:93f7227ba4ab94678c4498b07fe...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-02 15:17 EST by Sylvain Petreolle
Modified: 2012-03-07 14:09 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 03:55:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sylvain Petreolle 2012-03-02 15:17:20 EST
libreport version: 2.0.8
executable:     /usr/bin/python
hashmarkername: setroubleshoot
kernel:         3.2.7-1.fc16.x86_64
reason:         SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the None bootcd.iso.
time:           ven. 02 mars 2012 21:16:43 CET

description:
:SELinux is preventing /usr/bin/qemu-kvm from 'open' accesses on the None bootcd.iso.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that qemu-kvm should be allowed open access on the bootcd.iso <Inconnu> by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep qemu-kvm /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:s(removed)_t:s0:c183,c650
:Target Context                system_u:object_r:cifs_t:s0
:Target Objects                bootcd.iso [ None ]
:Source                        qemu-kvm
:Source Path                   /usr/bin/qemu-kvm
:Port                          <Inconnu>
:Host                          (removed)
:Source RPM Packages           qemu-system-x86-0.15.1-4.fc16.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.10.0-75.fc16.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.2.7-1.fc16.x86_64 #1 SMP Tue Feb 21
:                              01:40:47 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    ven. 02 mars 2012 20:09:14 CET
:Last Seen                     ven. 02 mars 2012 20:09:14 CET
:Local ID                      5767af12-5bf6-46e4-8e7f-fa6d785bd004
:
:Raw Audit Messages
:type=AVC msg=audit(1330715354.748:1533): avc:  denied  { open } for  pid=3028 comm="qemu-kvm" name="bootcd.iso" dev=cifs ino=45317471250808295 scontext=system_u:system_r:s(removed)_t:s0:c183,c650 tcontext=system_u:object_r:cifs_t:s0 tclass=filenode=(removed) type=SYSCALL msg=audit(1330715354.748:1533): arch=c000003e syscall=2 success=no exit=-13 a0=7f58b7c3a330 a1=81000 a2=0 a3=48 items=0 ppid=1 pid=3028 auid=4294967295 uid=107 gid=107 euid=107 suid=107 fsuid=107 egid=107 sgid=107 fsgid=107 tty=(none) ses=4294967295 comm="qemu-kvm" exe="/usr/bin/qemu-kvm" subj=system_u:system_r:s(removed)_t:s0:c183,c650 key=(null)
:
:
:Hash: qemu-kvm,s(removed)_t,cifs_t,None,open
:
:audit2allow
:
:
:audit2allow -R
:
:
Comment 1 Miroslav Grepl 2012-03-05 03:55:39 EST
You will need to turn on the virt_use_samba boolean

$ setsebool -P virt_use_samba 1
Comment 2 Sylvain Petreolle 2012-03-07 07:55:17 EST
Thanks for the feedback.
Why is this disabled by default ?
I didn't find an answer in the available documentation.
Comment 3 Daniel Walsh 2012-03-07 14:09:10 EST
Because it allows a virtual machine to read any data on your system that is being shared via samba.  Most people to not share their hosts samba data with their virtual machines.

Note You need to log in before you can comment on or make changes to this bug.