Bug 799538 - promotions -> errata -> packages filter causes page reload on click
promotions -> errata -> packages filter causes page reload on click
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Unspecified Unspecified
low Severity low (vote)
: Unspecified
: --
Assigned To: Jason E. Rist
Og Maciel
: Triaged
Depends On:
  Show dependency treegraph
Reported: 2012-03-02 17:10 EST by Justin Sherrill
Modified: 2013-08-16 14:06 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The page reloads unexpectedly when using the search feature to search for errata packages to add to a changeset. This fix corrects the filters for "click event". The search field now automatically loads results without reloading the whole page.
Story Points: ---
Clone Of:
Last Closed: 2012-12-04 14:42:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2012-03-02 17:10:44 EST
Description of problem:

Steps to Reproduce:
1. go to promotions
2. navigate down to some errata list
3. click on the errata
4.  click on packages (in the pane)
5. Type some search term
6. Click the magnifying glass  

Actual results:
Page reload

Expected results:
No page reload

Additional info:

Just typing triggers the filter, so really the hour glass doesn't even need to exist, at a minimum clicking shouldn't do anything.
Comment 1 Jason E. Rist 2012-03-12 12:46:14 EDT
commit 738eb3c416727de3bf6b06e71b351c54c5fb5595
Author: Jason E. Rist <jrist@redhat.com>
Date:   Mon Mar 12 10:43:22 2012 -0600

    799538 - Fix for filters "click" event, as well as icon placement.
Comment 2 Sachin Ghai 2012-03-22 08:15:03 EDT
Tested with following cfse build, the reported issue is still persists as page is still reloading. Please see the attachment, on clicking the magnifying glass page reloads.

Comment 4 Mike McCune 2012-05-10 13:42:33 EDT
moving to 1.1, severity is too low for 1.0.z
Comment 6 Og Maciel 2012-10-04 17:47:14 EDT
Verified using:

* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-12.el6cf.noarch
* katello-all-1.1.12-12.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-6.el6cf.noarch
* katello-cli-common-1.1.8-6.el6cf.noarch
* katello-common-1.1.12-12.el6cf.noarch
* katello-configure-1.1.9-6.el6cf.noarch
* katello-glue-candlepin-1.1.12-12.el6cf.noarch
* katello-glue-pulp-1.1.12-12.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch
Comment 8 errata-xmlrpc 2012-12-04 14:42:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

Comment 9 Mike McCune 2013-08-16 14:06:01 EDT
getting rid of 6.0.0 version since that doesn't exist

Note You need to log in before you can comment on or make changes to this bug.