Bug 799585 - [abrt] kernel: WARNING: at fs/sysfs/dir.c:481 sysfs_add_one+0x95/0xd0()
[abrt] kernel: WARNING: at fs/sysfs/dir.c:481 sysfs_add_one+0x95/0xd0()
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:912939052dd14c5c8a6ea05ce92...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 03:38 EST by michae1t
Modified: 2012-03-07 16:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 16:10:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description michae1t 2012-03-03 03:38:42 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-rc5+ root=/dev/mapper/vg_none-LogVol01 ro rd.md=0 rd.dm=0 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_none/LogVol01 rd.lvm.lv=vg_none/LogVol00 rd.luks=0 LANG=en_US.UTF-8
kernel:         3.3.0-rc5+
reason:         WARNING: at fs/sysfs/dir.c:481 sysfs_add_one+0x95/0xd0()
time:           Sat 03 Mar 2012 03:34:13 AM EST

backtrace:
:WARNING: at fs/sysfs/dir.c:481 sysfs_add_one+0x95/0xd0()
:Hardware name: MacBookPro8,2
:sysfs: cannot create duplicate filename '/class/backlight/acpi_video0'
:Modules linked in: video(+) uinput apple_bl sunrpc firewire_ohci sdhci_pci sdhci firewire_core mmc_core crc_itu_t radeon ttm drm_kms_helper drm i2c_algo_bit i2c_core
:Pid: 506, comm: modprobe Not tainted 3.3.0-rc5+ #11
:Call Trace:
: [<c04370c2>] warn_slowpath_common+0x72/0xa0
: [<c058c455>] ? sysfs_add_one+0x95/0xd0
: [<c058c455>] ? sysfs_add_one+0x95/0xd0
: [<c0437193>] warn_slowpath_fmt+0x33/0x40
: [<c058c455>] sysfs_add_one+0x95/0xd0
: [<c058cc85>] sysfs_do_create_link+0xe5/0x1d0
: [<c058b5d5>] ? sysfs_add_file_mode+0x85/0xb0
: [<c058cd87>] sysfs_create_link+0x17/0x20
: [<c071432e>] device_add+0x2ee/0x670
: [<c071d2ee>] ? device_pm_init+0x4e/0x70
: [<c07146c7>] device_register+0x17/0x20
: [<c069d09b>] backlight_device_register+0xeb/0x200
: [<faead590>] acpi_video_bus_add+0x862/0xb16 [video]
: [<c058bec8>] ? sysfs_new_dirent+0x48/0xf0
: [<c06a47e7>] acpi_device_probe+0x41/0xf5
: [<c0716919>] driver_probe_device+0x89/0x2d0
: [<c06a4c21>] ? acpi_match_device_ids+0x32/0x54
: [<c0716bf1>] __driver_attach+0x91/0xa0
: [<c0716b60>] ? driver_probe_device+0x2d0/0x2d0
: [<c0715162>] bus_for_each_dev+0x42/0x70
: [<c0716591>] driver_attach+0x21/0x30
: [<c0716b60>] ? driver_probe_device+0x2d0/0x2d0
: [<c0716207>] bus_add_driver+0x197/0x2a0
: [<c064ea6d>] ? kset_find_obj+0x2d/0x60
: [<c06a471b>] ? acpi_device_hid+0x1c/0x1c
: [<c07170b6>] driver_register+0x66/0x110
: [<c067346b>] ? pci_get_subsys+0x6b/0x90
: [<c06a4f5b>] acpi_bus_register_driver+0x3f/0x41
: [<faeacc3f>] acpi_video_register+0x1d/0x36 [video]
: [<faeb007a>] acpi_video_init+0x69/0x6b [video]
: [<c0401124>] do_one_initcall+0x34/0x170
: [<faeb0011>] ? video_set_bqc_offset+0x11/0x11 [video]
: [<c048f25c>] sys_init_module+0xeac/0x1c00
: [<c092eb5f>] sysenter_do_call+0x12/0x28

smolt_data:
:
:
:General
:=================================
:UUID: b5eea7d8-42a0-46d6-b871-3c4f1a1c17e5
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4589.77
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2820QM CPU @ 2.30GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2301
:System Memory: 7996
:System Swap: 7999
:Vendor: Apple Inc.
:System: MacBookPro8,2 1.0
:Form factor: Notebook
:Kernel: 3.3.0-rc5+
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:7241:32902:29296) pci, None, PCI/ISA, HM65 Express Chipset Family LPC Controller
:(5348:5820:5348:0) pci, sdhci-pci, BASE, NetXtreme BCM57765 Memory Card Reader
:(4545:22785:4545:22784) pci, firewire_ohci, FIREWIRE, FW643 PCI Express1394b Controller (PHY/Link)
:(32902:7188:32902:29296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7169:32902:29296) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7184:32902:29296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:32902:29296) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:32902:29296) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(32902:257:4203:220) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(32902:7202:32902:29296) pci, None, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(5348:17201:5348:17201) pci, bcma-pci-bridge, NETWORK, BCM4331 802.11a/b/g/n
:(5348:5812:5348:5812) pci, tg3, ETHERNET, NetXtreme BCM57765 Gigabit Ethernet PCIe
:(32902:7206:32902:29296) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(4098:26433:4203:226) pci, radeon, VIDEO, NI Whistler [AMD Radeon HD 6600M Series]
:(32902:7212:32902:29296) pci, uhci_hcd, USB, N/A
:(32902:7207:32902:29296) pci, uhci_hcd, USB, N/A
:(32902:260:4203:220) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:7226:32902:29296) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4098:43664:0:43664) pci, snd_hda_intel, MULTIMEDIA, N/A
:(32902:261:4203:220) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(32902:7213:32902:29296) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_none-LogVol01 / ext4 4096 4096 5103904 2754017 2498017 1281120 991265 991265
:/dev/sda4 /boot ext4 1024 1024 267557 172372 158856 67584 67355 67355
:/dev/mapper/luks-68418606-1590-4572-aefc-d5912e2f77ed /home ext4 4096 4096 41552770 17669347 15589015 10403840 10105969 10105969
:
Comment 1 Josh Boyer 2012-03-07 16:10:30 EST
(In reply to comment #0)
> libreport version: 2.0.8
> abrt_version:   2.0.7
> cmdline:        BOOT_IMAGE=/vmlinuz-3.3.0-rc5+
> root=/dev/mapper/vg_none-LogVol01 ro rd.md=0 rd.dm=0 KEYTABLE=us quiet
> SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_none/LogVol01
> rd.lvm.lv=vg_none/LogVol00 rd.luks=0 LANG=en_US.UTF-8
> kernel:         3.3.0-rc5+

You seem to have built your own kernel.  If you see this on a stock Fedora kernel, please open a new bug with relevant details.

*** This bug has been marked as a duplicate of bug 126342 ***

Note You need to log in before you can comment on or make changes to this bug.