Bug 799619 - gnome-shell-extension-cpu-temperature displays incorrect value
gnome-shell-extension-cpu-temperature displays incorrect value
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-shell-extension-cpu-temperature (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fabian Affolter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 10:52 EST by Steevithak
Modified: 2012-03-10 12:58 EST (History)
2 users (show)

See Also:
Fixed In Version: gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 14:22:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steevithak 2012-03-03 10:52:16 EST
Description of problem:
I installed Fedora 16 and gnome-shell-extension-cpu-temperature. A temperature of 26.8 C is always displayed on the top toolbar regardless of actual CPU, GPU, HD, and other internal temperatures. I previously ran Fedora 14 and the toolbar temp monitor displayed temperatures for each sensor separately and correctly. Presumably the new version is averaging all the temps into one value or only displaying one of the sensors? But it should still vary over time and at least approximate some actual internal temperature to be useful.

Version-Release number of selected component (if applicable):
gnome-shell-extension-cpu-temperature-0-0.3.git1f471c7.fc16.noarch

How reproducible:
always

Steps to Reproduce:
1. install Fedora 16
2. install gnome-shell-extension-cpu-temperature
3. watch it display 26.8C forever 
  
Actual results:
Displays a static string reading 26.8C

Expected results:
Displays temperature of CPU or some other actual internal temperature

Additional info:
I'm using a Dell Studio 15 laptop Dell Studio 1558 with Intel i3 and ATI graphics. I seem to recall Fedora 14 initially had trouble reading temps on this model laptop but didn't see a bug related to this.

Also, it would be nice to display multiple temps like the old version did if this is possible.
Comment 1 Fedora Update System 2012-03-04 04:32:00 EST
gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/FEDORA-2012-2463/gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc17
Comment 2 Fedora Update System 2012-03-04 04:33:11 EST
gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2012-2451/gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc16
Comment 3 Fabian Affolter 2012-03-04 04:35:12 EST
Please report feature request to the upstream project [1]. Thanks.

[1] https://github.com/xtranophilist/gnome-shell-extension-cpu-temperature/
Comment 4 Fedora Update System 2012-03-06 14:22:31 EST
gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2012-03-06 15:32:26 EST
gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 Steevithak 2012-03-10 12:58:30 EST
The problem is still  present in gnome-shell-extension-cpu-temperature-0-0.4.gite1777e6.fc16

It's still not displaying an actual CPU temperature, just a static reading of 26.8 C all the time.

Note You need to log in before you can comment on or make changes to this bug.