Bug 799630 - [abrt] SwWW8ImplReader::emulateMSWordAddTextToParagraph
[abrt] SwWW8ImplReader::emulateMSWordAddTextToParagraph
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:d9f9a3613aef7b32fef37c6e2a2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-03 12:23 EST by Filippo Racca
Modified: 2012-03-27 05:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-27 05:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (18.06 KB, text/plain)
2012-03-03 12:23 EST, Filippo Racca
no flags Details
File: smolt_data (5.96 KB, text/plain)
2012-03-03 12:23 EST, Filippo Racca
no flags Details
File: maps (74.23 KB, text/plain)
2012-03-03 12:24 EST, Filippo Racca
no flags Details
File: backtrace (88.37 KB, text/plain)
2012-03-03 12:24 EST, Filippo Racca
no flags Details

  None (edit)
Description Filippo Racca 2012-03-03 12:23:52 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///media/ILENIA/raineri/nmr+epr/rilassamento-materiale%20supplementare.doc --splash-pipe=7
comment:        Opened a doc file
crash_function: operator!=
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.2.7-1.fc16.x86_64
pid:            5016
pwd:            /home/pippo
reason:         Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
time:           sab 03 mar 2012 16:27:05 CET
uid:            1000
username:       pippo

backtrace:      Text file, 90494 bytes
dso_list:       Text file, 18490 bytes
maps:           Text file, 76011 bytes
smolt_data:     Text file, 6108 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=Cocito
:LC_MONETARY=it_IT.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=5005
:GPG_AGENT_INFO=/tmp/keyring-Di6cKu/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-1756-hostname-libreoffice-20_TIME7487963
:HISTSIZE=1000
:XDG_SESSION_COOKIE=a856aa25431b34505935603c00000009-1330780999.360030-756639987
:LC_NUMERIC=it_IT.utf8
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-Di6cKu
:IMSETTINGS_MODULE=none
:USER=user
:DESKTOP_AUTOSTART_ID=10405a95916c4519ff133078099968997800000015140023
:SSH_AUTH_SOCK=/tmp/keyring-Di6cKu/ssh
:USERNAME=user
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1514,unix/unix:/tmp/.ICE-unix/1514
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-writer.desktop
:MAIL=/var/spool/mail/user
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/user/.local/bin:/home/pippo/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/user
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1508
:LANG=it_IT.utf8
:GDM_LANG=it_IT.utf8
:LC_MEASUREMENT=it_IT.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/user
:XDG_SEAT=seat0
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=user
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-fIdH2Jjp62,guid=87bcfcd24ca66723497fdcc00000003f
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/user
:DISPLAY=:0.0
:LC_TIME=it_IT.utf8
:XAUTHORITY=/var/run/gdm/auth-for-pippo-vZ8ueg/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64

event_log:
:2012-03-03-16:27:54> Interrogazione settaggio server
:2012-03-03-16:27:55  Preparazione archivio da caricare
:2012-03-03-16:27:58  Upload 3 megabyte
:2012-03-03-16:28:08  Caricamento di 37%
:2012-03-03-16:28:22  Caricamento di 72%
:2012-03-03-16:28:28  Caricamento completato con successo
:2012-03-03-16:28:36  Avviato lavoro di tracciamento
:2012-03-03-16:28:48  Analyzing crash data
:2012-03-03-16:28:59  Initializing virtual root
:2012-03-03-16:29:10  Initializing virtual root
:2012-03-03-16:29:21  Initializing virtual root
:2012-03-03-16:29:32  Initializing virtual root
:2012-03-03-16:29:43  Initializing virtual root
:2012-03-03-16:29:54  Initializing virtual root
:2012-03-03-16:30:05  Initializing virtual root
:2012-03-03-16:30:16  Initializing virtual root
:2012-03-03-16:30:27  Initializing virtual root
:2012-03-03-16:30:38  Initializing virtual root
:2012-03-03-16:30:49  Initializing virtual root
:2012-03-03-16:31:00  Initializing virtual root
:2012-03-03-16:31:11  Initializing virtual root
:2012-03-03-16:31:21  Initializing virtual root
:2012-03-03-16:31:32  Initializing virtual root
:2012-03-03-16:31:43  Initializing virtual root
:2012-03-03-16:31:54  Initializing virtual root
:2012-03-03-16:32:05  Initializing virtual root
:2012-03-03-16:32:15  Initializing virtual root
:2012-03-03-16:32:26  Initializing virtual root
:2012-03-03-16:32:37  Initializing virtual root
:2012-03-03-16:32:48  Initializing virtual root
:2012-03-03-16:32:59  Initializing virtual root
:2012-03-03-16:33:10  Initializing virtual root
:2012-03-03-16:33:20  Initializing virtual root
:2012-03-03-16:33:31  Initializing virtual root
:2012-03-03-16:33:42  Initializing virtual root
:2012-03-03-16:33:53  Initializing virtual root
:2012-03-03-16:34:04  Initializing virtual root
:2012-03-03-16:34:15  Initializing virtual root
:2012-03-03-16:34:25  Initializing virtual root
:2012-03-03-16:34:36  Initializing virtual root
:2012-03-03-16:34:47  Initializing virtual root
:2012-03-03-16:34:58  Initializing virtual root
:2012-03-03-16:35:09  Initializing virtual root
:2012-03-03-16:35:20  Initializing virtual root
:2012-03-03-16:35:30  Initializing virtual root
:2012-03-03-16:35:41  Initializing virtual root
:2012-03-03-16:35:52  Initializing virtual root
:2012-03-03-16:36:03  Initializing virtual root
:2012-03-03-16:36:14  Initializing virtual root
:2012-03-03-16:36:24  Initializing virtual root
:2012-03-03-16:36:35  Initializing virtual root
:2012-03-03-16:36:46  Initializing virtual root
:2012-03-03-16:36:57  Initializing virtual root
:2012-03-03-16:37:08  Initializing virtual root
:2012-03-03-16:37:19  Initializing virtual root
:2012-03-03-16:37:29  Initializing virtual root
:2012-03-03-16:37:40  Initializing virtual root
:2012-03-03-16:37:51  Initializing virtual root
:2012-03-03-16:38:02  Initializing virtual root
:2012-03-03-16:38:13  Initializing virtual root
:2012-03-03-16:38:23  Initializing virtual root
:2012-03-03-16:38:34  Initializing virtual root
:2012-03-03-16:38:45  Initializing virtual root
:2012-03-03-16:38:56  Initializing virtual root
:2012-03-03-16:39:07  Initializing virtual root
:2012-03-03-16:39:18  Initializing virtual root
:2012-03-03-16:39:28  Initializing virtual root
:2012-03-03-16:39:39  Initializing virtual root
:2012-03-03-16:39:50  Initializing virtual root
:2012-03-03-16:40:01  Generating backtrace
:2012-03-03-16:40:12  Generating backtrace
:2012-03-03-16:40:23  Cleaning up virtual root
:2012-03-03-16:40:33  Retrace job finished successfully
:2012-03-03-16:44:58> Smolt profile successfully saved

var_log_messages:
:Mar  3 16:27:05 Cocito kernel: [ 7486.157308] soffice.bin[5016]: segfault at 8 ip 00007fa4c0f2334d sp 00007fff29a3a9c0 error 4 in libmswordlx.so[7fa4c0e23000+1aa000]
:Mar  3 16:27:05 Cocito abrt[5030]: Saved core dump of pid 5016 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-03-03-16:27:05-5016 (94830592 bytes)
Comment 1 Filippo Racca 2012-03-03 12:23:57 EST
Created attachment 567305 [details]
File: dso_list
Comment 2 Filippo Racca 2012-03-03 12:23:59 EST
Created attachment 567306 [details]
File: smolt_data
Comment 3 Filippo Racca 2012-03-03 12:24:01 EST
Created attachment 567307 [details]
File: maps
Comment 4 Filippo Racca 2012-03-03 12:24:05 EST
Created attachment 567308 [details]
File: backtrace
Comment 5 David Tardon 2012-03-05 06:51:25 EST
dtardon->caolanm: The problem seems to be that nForceFromFontId is 0. Perhaps we should do nothing in that case? Or set it to RES_CHRATR_FONT by default?
Comment 6 David Tardon 2012-03-05 06:52:16 EST
Could you attach the doc file here?
Comment 7 Caolan McNamara 2012-03-05 09:27:45 EST
Hmm, I guess we could have a busted nIdctHint value that sets some gibberish into nLclIdctHint, which is optimized out here, grr.

If you can attach a reproducer I'd be certain
Comment 8 Caolan McNamara 2012-03-27 05:22:00 EDT
Can only assume its an unknown or broken nIdctHint value, if so...
 http://cgit.freedesktop.org/libreoffice/core/commit/?id=b1bb3821f47cc5031798e62e2fecad3bb5dfd6ba
would fix it

Note You need to log in before you can comment on or make changes to this bug.