Bug 799673 - transmission-qt.desktop does not provide magnetic link MimeType
transmission-qt.desktop does not provide magnetic link MimeType
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: transmission (Show other bugs)
rawhide
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Kalev Lember
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 01:12 EST by Fabio Massimo Di Nitto
Modified: 2013-02-01 12:03 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-01 11:43:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (1.23 KB, patch)
2012-03-04 01:14 EST, Fabio Massimo Di Nitto
no flags Details | Diff

  None (edit)
Description Fabio Massimo Di Nitto 2012-03-04 01:12:17 EST
Description of problem:

If I have only transmission-qt installed on my system and I click on a
magnetic link, firefox reports the usual error that it doesn't know
how to handle magnetic links.

Version-Release number of selected component (if applicable):

2.50-2

How reproducible:

Always

Steps to Reproduce:
1. Install transmission-qt on a xfce environment
2. Start firefox, open favourite torrent site
3. click on magnetic link
  
Actual results:

firefox errors out.

Expected results:

firefox should recognize transmission-qt as magnetic link handler.

Additional info:

patch in attachment to fix the problem ;)
Comment 1 Fabio Massimo Di Nitto 2012-03-04 01:14:59 EST
Created attachment 567372 [details]
proposed patch

PS I can also build/commit if necessary. Please let me know.

Tested on F16 (don't have a Fedora rawhide desktop).

Changing %F to %U is also necessary. Using %f nothing happens. %U is the same var used by trasmission-gtk and brings you straight to the "add" menu.
Comment 2 Fabio Massimo Di Nitto 2012-11-23 00:21:59 EST
I am re-assigning the current active maintainer.

The issue is still present in all versions of transmission (rawhide/f18/17/16).

would be very nice to have this fixed.

The patch was done against f16, beside the spec file change, the patch is still valid.
Comment 3 Kalev Lember 2012-11-23 07:33:30 EST
Looks like there are two versions of transmission-qt.desktop, one of which ships with the Fedora package, and another one which is included in the transmission upstream tarball.

It would appear that the desktop file in the upstream tarball already has the x-scheme-handler/magnet mimetype.

I'll update the package to use the upstream desktop file, which should fix the mimetype issue. However, the %F -> %U change might still be needed. Can you verify this and file a ticket with upstream to change %F -> %U if needed?

Upstream issue tracker: https://trac.transmissionbt.com/
Comment 4 Fabio Massimo Di Nitto 2012-11-23 13:11:13 EST
(In reply to comment #3)
> Looks like there are two versions of transmission-qt.desktop, one of which
> ships with the Fedora package, and another one which is included in the
> transmission upstream tarball.
> 
> It would appear that the desktop file in the upstream tarball already has
> the x-scheme-handler/magnet mimetype.
> 
> I'll update the package to use the upstream desktop file, which should fix
> the mimetype issue. However, the %F -> %U change might still be needed. Can
> you verify this and file a ticket with upstream to change %F -> %U if needed?
> 
> Upstream issue tracker: https://trac.transmissionbt.com/

I verified that %U is still necessary.

No sorry I won't file a bug upstream as that needs yet another account.
Also, as part of being a packager, you should already be in touch with upstream that would make things a lot easier.

There are other differences in the .desktop that might need revisit, either by fedora or upstream (or both).

[fabbione@jeeg qt]$ diff -u ../../transmission-qt.desktop transmission-qt.desktop

-Icon=transmission
+Icon=transmission-qt

^^ this one probably needs check for how the two packages ship the icon.

+X-AppInstall-Keywords=torrent
+Actions=Minimize;
+
+[Desktop Action Minimize]
+_Name=Start Transmission Minimized
+Exec=transmission-qt --minimized
+OnlyShowIn=Unity;
+

^^ I have no idea how this section work. That "OnlyShowIn" sounds very much Ubuntu specific and would have to be checked in Fedora.

Thanks
Fabio
Comment 5 Fedora Update System 2013-01-19 21:25:46 EST
transmission-2.76-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/transmission-2.76-1.fc18
Comment 6 Fedora Update System 2013-01-19 21:27:13 EST
transmission-2.76-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/transmission-2.76-1.fc17
Comment 7 Fedora Update System 2013-01-22 20:36:09 EST
Package transmission-2.76-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing transmission-2.76-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-1207/transmission-2.76-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-02-01 11:43:55 EST
transmission-2.76-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2013-02-01 12:03:03 EST
transmission-2.76-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.