This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 799685 - oom-killer activates when plenty of RAM is still available
oom-killer activates when plenty of RAM is still available
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 04:41 EST by Slawomir Czarko
Modified: 2012-03-14 10:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-14 10:43:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Section of /var/log/messages (252.11 KB, application/octet-stream)
2012-03-05 03:52 EST, Slawomir Czarko
no flags Details
dmesg output (123.66 KB, application/octet-stream)
2012-03-14 08:44 EDT, Slawomir Czarko
no flags Details
/var/log/messages (424.05 KB, application/octet-stream)
2012-03-14 08:44 EDT, Slawomir Czarko
no flags Details

  None (edit)
Description Slawomir Czarko 2012-03-04 04:41:31 EST
Description of problem:

After updating to kernel 2.6.42.7-1.fc15.i686.PAE I'm getting oom-killer activated every few hours. I think this might be related to the bug 745241 or 735946 since I've been using fuse and rsync during that time (regression?).


Version-Release number of selected component (if applicable):
2.6.42.7-1.fc15.i686.PAE

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Dave Jones 2012-03-04 21:48:47 EST
we can't do anything with this report without seeing logs from the oomkiller.
Comment 2 Slawomir Czarko 2012-03-05 03:52:10 EST
Created attachment 567529 [details]
Section of /var/log/messages

This shows what was logged to /var/log/messages when oom-killer activated.

Do you need any other logs?
Comment 3 Slawomir Czarko 2012-03-14 08:43:25 EDT
Just got this again now with 2.6.41.10-3 PAE kernel. Attaching dmesg and /var/log/messages
Comment 4 Slawomir Czarko 2012-03-14 08:44:06 EDT
Created attachment 569971 [details]
dmesg output
Comment 5 Slawomir Czarko 2012-03-14 08:44:36 EDT
Created attachment 569972 [details]
/var/log/messages
Comment 6 Slawomir Czarko 2012-03-14 08:46:34 EDT
Machine has 16 GB RAM and there's a few GB always free (or used by filesystem cache). Swap is either not used or barely (less than 100MB).
Comment 7 Slawomir Czarko 2012-03-14 08:47:25 EDT
Any suggestions on how to debug this?
Comment 8 Slawomir Czarko 2012-03-14 09:13:57 EDT
Is this due to PAE kernel?

Do you think changing value for vm.lowmem_reserve_ratio will help?
Comment 9 Dave Jones 2012-03-14 10:43:30 EDT
the real answer is to move to 64bit. Past 8GB, 32bit gets complicated because of so much low memory being used up by page tables. Once fragmentation starts to happen, this sort of thing is to be expected.

You might have memory free when the oom is triggering, but the problem is that you don't have any of the right 'type' of memory (the gfp mask) free.

You might make it perform a bit better by tweaking syscalls, but you're fundamentally in a losing battle just because you're pushing up against the architectural limits.

Note You need to log in before you can comment on or make changes to this bug.