Bug 799690 - Ignore the ignorable openswan messages
Ignore the ignorable openswan messages
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
Ondrej Hudlicky
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 06:15 EST by Matěj Cepl
Modified: 2014-01-30 04:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 09:39:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch (2.77 KB, patch)
2012-08-15 03:07 EDT, Jan Synacek
no flags Details | Diff
Reproducer (10.00 KB, application/x-tar)
2013-06-12 02:58 EDT, Jan Synacek
no flags Details

  None (edit)
Description Matěj Cepl 2012-03-04 06:15:44 EST
Description of problem:

Every day I get in the logwatch email in FreeS/WAN (BTW, the name is wrong, we are using Openswan) a lot of messages like the following. Most of them are just ignorable and should be eliminated from the logwatch report:

UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: ERROR: "nm-conn1" #2: sendto on wlan0 to 209.132.186.252:4500 failed in delete notify. Errno 22: Invalid argument
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: RTNETLINK answers: Network is unreachable
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: RTNETLINK answers: Network is unreachable
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: /usr/libexec/ipsec/_updown.netkey: doroute `ip route del 172.16.0.0/16  dev wlan0 ' failed (RTNETLINK answers: No such process)
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: RTNETLINK answers: Network is unreachable
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: RTNETLINK answers: Network is unreachable
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: down-client output: /usr/libexec/ipsec/_updown.netkey: doroute `ip route del 10.0.0.0/8  dev wlan0 ' failed (RTNETLINK answers: No such process)
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: Restoring resolv.conf is controlled by Network Manager
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: sending disconnect signal to NetworkManager
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: 
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: ** (process:6634): WARNING **: <WARN>  helper_disconnect(): nm-openswan-service-helper received disconnect from openswan
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: 
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: 
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: ** (process:6634): WARNING **: <WARN>  helper_disconnect(): Could not send failure information: Could not process the request because no VPN connection was active.
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: "nm-conn1" #2: restoreresolvconf-client output: 
 UNKNOWN: Mar  3 01:51:09 mitmanek pluto[7991]: ERROR: "nm-conn1" #1: sendto on wlan0 to 209.132.186.252:4500 failed in delete notify. Errno 22: Invalid argument
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: multiple DH groups were set in aggressive mode. Only first one used.
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: transform (7,2,2,0) ignored.
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: initiating Aggressive Mode #1, connection "nm-conn1"
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: multiple DH groups were set in aggressive mode. Only first one used.
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: transform (7,2,2,0) ignored.
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: ignoring Vendor ID payload [FRAGMENTATION c0000000]
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: ignoring Vendor ID payload [Cisco VPN 3000 Series]
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: protocol/port in Phase 1 ID Payload must be 0/0 or 17/500 but are 17/0
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: Aggressive mode peer ID is ID_IPV4_ADDR: '209.132.186.252'
 UNKNOWN: Mar  3 12:05:38 mitmanek pluto[15530]: "nm-conn1" #1: XAUTH: Bad Message: Enter Username and Password.
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: XAUTH: Answering XAUTH challenge with user='mcepl'
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: STATE_XAUTH_I1: XAUTH client - awaiting CFG_set
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: XAUTH: Successfully Authenticated
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: STATE_XAUTH_I1: XAUTH client - awaiting CFG_set
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: modecfg: Sending IP request (MODECFG_I1)
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: received mode cfg reply
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: setting client address to 10.36.4.76/32
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: setting ip source address to 10.36.4.76/32
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: Received IP4 NETMASK 255.255.252.0
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: Received DNS 10.33.63.7, len=10
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: Received DNS 10.32.63.5, len=10
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: Received subnet 172.16.0.0/16, maskbits 16
 UNKNOWN: Mar  3 12:05:41 mitmanek pluto[15530]: "nm-conn1" #1: Received subnet 10.0.0.0/8, maskbits 8
 UNKNOWN: Mar  3 12:05:42 mitmanek pluto[15530]: "nm-conn1" #2: updateresolvconf-client output: Updating resolv.conf is controlled by Network Manager


Version-Release number of selected component (if applicable):
logwatch-7.3.6-49.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.use openswan (via NetworkManager plugin)
2.
3.
  
Actual results:
get a ton of junk in email

Expected results:
only important messages are in the email

Additional info:
Feel free to reassign to Fedora product if it will make it faster fixed.
Comment 2 Jan Synacek 2012-08-15 03:07:55 EDT
Created attachment 604518 [details]
Patch
Comment 8 Jan Synacek 2013-06-12 02:58:36 EDT
Created attachment 759965 [details]
Reproducer

How to test:

1) untar
2) sh test-pluto.sh
3a - before) a lot of "UNKNOWN: ..." lines as mentioned in the description
3b - after) no "UNKNOWN: ..." spam, only useful information
Comment 11 errata-xmlrpc 2013-09-10 09:39:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1247.html

Note You need to log in before you can comment on or make changes to this bug.