Bug 799734 - Intel graphics and Dell monitor can't agree on color format after kernel 3.2 upgrade
Intel graphics and Dell monitor can't agree on color format after kernel 3.2 ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
16
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 14:39 EST by Stephen Gallagher
Modified: 2012-10-29 09:25 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-29 09:25:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of xrandr --props (1.09 KB, text/plain)
2012-03-09 16:52 EST, Stephen Gallagher
no flags Details

  None (edit)
Description Stephen Gallagher 2012-03-04 14:39:20 EST
Description of problem:
Smolt profile: http://www.smolts.org/client/show/pub_59504ccf-2549-468d-b5fe-ccf285160a58
I have a Dell Studio Hybrid with Intel Graphics (see below) and a Dell monitor ST2320Lf connected via HDMI.

Version-Release number of selected component (if applicable):
kernel-3.2.6-3.fc16.x86_64 and kernel-3.2.7-1.fc16.x86_64 both experience the issue. Downgrading to kernel-3.1.6-1.fc16.x86_64 restores proper behaviour.


How reproducible:
Every time

Steps to Reproduce:
1. Install kernel 3.2
2. Reboot
  
Actual results:
Screen appears to be bright pink with green highlights. Examining the monitor's menu shows that the monitor is attempting to run in YPbPr mode, though the graphics card is outputting data in RGB mode. Prior to the kernel update, the monitor would always properly autodetect RGB mode and display properly.

Expected results:
The monitor should correctly display the UI in the proper color space, without the user being forced to manually select the color mode.

Additional info:
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 03)

I can provide additional details about the hardware as requested, and I am available to test any proposed fix.

This appears to be a purely kernel issue, as I did not have to make any changes to xorg-x11-drv-intel to restore functionality. I only had to downgrade to kernel-3.1.6-1.fc16.x86_64
Comment 1 Stephen Gallagher 2012-03-09 16:52:53 EST
Created attachment 569003 [details]
Output of xrandr --props

As requested on IRC, I've attached the output of 'xrandr --props' to the BZ. It should provide you with the EDID you needed.
Comment 2 Stephen Gallagher 2012-04-03 09:50:17 EDT
Just wondering if there has been any progress on this (or whether additional information is needed to track it down). We're currently holding the kernel on 3.1.6-1.fc16 to retain proper color format, but I don't like doing this for too long, as the kernel has had security updates since then.
Comment 3 Stephen Gallagher 2012-05-29 11:30:04 EDT
Still looking for an update on this. Do we know if this has been fixed in recent kernels (or on Fedora 17) by any chance?
Comment 5 Stephen Gallagher 2012-08-07 11:15:24 EDT
I upgraded the machine with this issue to Fedora 17. It's worth noting that the Fedora 17 install DVD suffers from this issue, as does the initial boot. However, after applying all available updates and rebooting, the issue goes away.

This issue appears to have been resolved as of kernel-3.5.0-2.fc17 and xorg-x11-drv-intel-2.20.1-1.fc17.

I'm not sure whether you want to leave this bug open until the issue is addressed in Fedora 16.
Comment 6 Adam Jackson 2012-10-29 09:25:32 EDT
Closing, F16 has 3.6 now.

Note You need to log in before you can comment on or make changes to this bug.