Bug 799742 - [abrt] kernel: WARNING: at lib/dma-debug.c:930 check_for_stack+0xa9/0xf0()
[abrt] kernel: WARNING: at lib/dma-debug.c:930 check_for_stack+0xa9/0xf0()
Status: CLOSED DUPLICATE of bug 799731
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:530bccdf090c7830d3a94ef9338...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 16:43 EST by david.p.risley
Modified: 2012-03-04 21:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-04 21:44:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description david.p.risley 2012-03-04 16:43:57 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        initrd=initrd0.img root=live:CDLABEL=Fedora-17-Alpha-x86_64-Live-Desk rootfstype=auto ro liveimg quiet  rhgb rd.luks=0 rd.md=0 rd.dm=0  BOOT_IMAGE=vmlinuz0 
kernel:         3.3.0-0.rc3.git7.2.fc17.x86_64
reason:         WARNING: at lib/dma-debug.c:930 check_for_stack+0xa9/0xf0()
smolt_data:     Unable to save UUID to /etc/smolt/hw-uuid.  Please run once as root.
time:           Sun 04 Mar 2012 10:33:53 AM EST

backtrace:
:WARNING: at lib/dma-debug.c:930 check_for_stack+0xa9/0xf0()
:Hardware name: Aspire 5733Z
:ehci_hcd 0000:00:1d.0: DMA-API: device driver maps memory fromstack [addr=ffff88012e4ffc01]
:Modules linked in: hid_logitech_dj(+) snd_hwdep cfg80211 snd_pcm acer_wmi broadcom sparse_keymap rfkill snd_page_alloc iTCO_wdt microcode tg3 snd_timer i2c_i801 intel_ips iTCO_vendor_support snd soundcore uinput squashfs usb_storage mxm_wmi wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core
:Pid: 424, comm: udevd Not tainted 3.3.0-0.rc3.git7.2.fc17.x86_64 #1
:Call Trace:
: [<ffffffff81060bef>] warn_slowpath_common+0x7f/0xc0
: [<ffffffff81060ce6>] warn_slowpath_fmt+0x46/0x50
: [<ffffffff8169e294>] ? _raw_spin_unlock_irqrestore+0x44/0x80
: [<ffffffff8133ec89>] check_for_stack+0xa9/0xf0
: [<ffffffff8133f3da>] debug_dma_map_page+0xea/0x150
: [<ffffffff8148717b>] usb_hcd_map_urb_for_dma+0x54b/0x5d0
: [<ffffffff810283bf>] ? save_stack_trace+0x2f/0x50
: [<ffffffff8148748d>] usb_hcd_submit_urb+0x28d/0x870
: [<ffffffff81488700>] usb_submit_urb+0xf0/0x3b0
: [<ffffffff81489a02>] usb_start_wait_urb+0x82/0x1a0
: [<ffffffff81488b2e>] ? usb_alloc_urb+0x1e/0x50
: [<ffffffff81489d8e>] usb_control_msg+0xde/0x140
: [<ffffffff81235542>] ? sysfs_add_file+0x12/0x20
: [<ffffffff8152d222>] usbhid_output_raw_report+0xd2/0x100
: [<ffffffffa01e1661>] logi_dj_recv_send_report.isra.7+0x21/0x50 [hid_logitech_dj]
: [<ffffffffa01e16e1>] logi_dj_recv_switch_to_dj_mode.constprop.13+0x51/0x70 [hid_logitech_dj]
: [<ffffffffa01e2268>] logi_dj_probe+0x238/0x3dc [hid_logitech_dj]
: [<ffffffff8169e2fb>] ? _raw_spin_unlock+0x2b/0x50
: [<ffffffff8152369d>] hid_device_probe+0xbd/0x140
: [<ffffffff81411e36>] driver_probe_device+0x96/0x2f0
: [<ffffffff8141213b>] __driver_attach+0xab/0xb0
: [<ffffffff81412090>] ? driver_probe_device+0x2f0/0x2f0
: [<ffffffff81410035>] bus_for_each_dev+0x55/0x90
: [<ffffffffa01e7000>] ? 0xffffffffa01e6fff
: [<ffffffff8141191e>] driver_attach+0x1e/0x20
: [<ffffffff81411628>] bus_add_driver+0x1b8/0x2b0
: [<ffffffffa01e7000>] ? 0xffffffffa01e6fff
: [<ffffffff81412917>] driver_register+0x77/0x160
: [<ffffffffa01e7000>] ? 0xffffffffa01e6fff
: [<ffffffff81520a66>] __hid_register_driver+0x66/0xa0
: [<ffffffffa01e7047>] logi_dj_init+0x47/0x1000 [hid_logitech_dj]
: [<ffffffff8100212a>] do_one_initcall+0x12a/0x180
: [<ffffffff810daef6>] sys_init_module+0x1146/0x2260
: [<ffffffff816a6f29>] system_call_fastpath+0x16/0x1b
Comment 1 Dave Jones 2012-03-04 21:44:20 EST

*** This bug has been marked as a duplicate of bug 799731 ***

Note You need to log in before you can comment on or make changes to this bug.