This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 799772 - 3.3rc5 kernel fails to boot
3.3rc5 kernel fails to boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
All All
urgent Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F17Beta/F17BetaBlocker
  Show dependency treegraph
 
Reported: 2012-03-04 19:49 EST by Dan Mashal
Modified: 2012-03-07 23:12 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 23:12:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Boot with rdinitdebug on boot line (24.43 KB, image/png)
2012-03-04 19:51 EST, satellitgo
no flags Details

  None (edit)
Description Dan Mashal 2012-03-04 19:49:14 EST
Description of problem:

3.3 rc5 (0301 patch) kernel fails to boot and has bugs in the code.

Version-Release number of selected component (if applicable):

Linux-3.3.0-rc5-next-20120301

How reproducible:

Reproduced by a user in #fedora-qa IRC:

<satellit_> Fedora-17-Nightly-20120304.07-i686-Live-soas.iso boot fails drops to dracut shell  x86-64 version goes to gdm logs in then x-fails  FYI

Also, installed the kernel from updates-testing repo (so 3.3rc5.fc17) and I was unable to run make clean from the kernel source director due to missing Makefiles:



Steps to Reproduce:

One example:

1) Compile rc5 patch 0301 from source and attempt to boot.
2) Run make clean from 3.3 rc5 kernel source dir.
3) Install nightly i686 or amd64 version live cd per satellit's example.
  
Actual results:

First example:

http://i.imgur.com/Ua3bN.png

Second example:

[root@Fedora17 kernels]# cd 3.3.0-0.rc5.git3.1.fc17.x86_64/
[root@Fedora17 3.3.0-0.rc5.git3.1.fc17.x86_64]# make clean
scripts/Makefile.clean:17: /usr/src/kernels/3.3.0-0.rc5.git3.1.fc17.x86_64/fs/exofs/Makefile: No such file or directory
make[2]: *** No rule to make target `/usr/src/kernels/3.3.0-0.rc5.git3.1.fc17.x86_64/fs/exofs/Makefile'.  Stop.
make[1]: *** [fs/exofs] Error 2
make: *** [_clean_fs] Error 2
[root@Fedora17 3.3.0-0.rc5.git3.1.fc17.x86_64]# 



Expected results:

Move to Linux 3.3 rc6. Problem seems to be fixed. Fedora 17 boots fine.

[dan@Fedora17 ~]$ uname -a
Linux Fedora17 3.3.0-rc6 #1 SMP Sun Mar 4 15:43:31 PST 2012 x86_64 x86_64 x86_64 GNU/Linux
Comment 1 satellitgo 2012-03-04 19:51:29 EST
Created attachment 567439 [details]
Boot with rdinitdebug on boot line
Comment 2 Josh Boyer 2012-03-05 10:36:42 EST
You seem to have built your own kernel.  We can't do anything to help custom kernels.  F17/rawhide should move to -rc6 today, so I suppose your problem would have been fixed anyway.

*** This bug has been marked as a duplicate of bug 126342 ***
Comment 3 Dan Mashal 2012-03-05 10:43:03 EST
This is both stock and non stock rc5 kernels, but yes this would be fixed in RC6, Josh. 

Thanks.
Comment 4 Dan Mashal 2012-03-07 03:12:13 EST

*** This bug has been marked as a duplicate of bug 126342 ***
Comment 5 Dan Mashal 2012-03-07 23:10:26 EST
Fedora 17 / updates-testing repo has been updated to Linux kernel 3.3rc6 via yum update without any issues. Seems that ext4 debugging was also turned off, causing a major performance improvement as well.

Issue resolved.

Note You need to log in before you can comment on or make changes to this bug.