Bug 799776 - [abrt] ibus-hangul-1.4.0-3.fc17: main.py:109:__init__:GError: Failed to open file '/usr/share/ibus-hangul/icons/ibus-hangul.svg': No such file or directory
[abrt] ibus-hangul-1.4.0-3.fc17: main.py:109:__init__:GError: Failed to open ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus-hangul (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
abrt_hash:7a6e96d9c4eb49166b62ab9445b...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-04 20:10 EST by Joseph Cordero
Modified: 2012-04-11 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: ibus-hangul-1.4.0-5.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-26 05:32:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Cordero 2012-03-04 20:10:42 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        python /usr/share/ibus-hangul/setup/main.py
event_log:      2012-03-04-20:09:11> Smolt profile successfully saved
executable:     /usr/share/ibus-hangul/setup/main.py
kernel:         3.3.0-0.rc5.git3.1.fc17.x86_64
reason:         main.py:109:__init__:GError: Failed to open file '/usr/share/ibus-hangul/icons/ibus-hangul.svg': No such file or directory
time:           Sun 04 Mar 2012 07:43:04 PM EST
uid:            1000
username:       joseph

backtrace:
:main.py:109:__init__:GError: Failed to open file '/usr/share/ibus-hangul/icons/ibus-hangul.svg': No such file or directory
:
:Traceback (most recent call last):
:  File "/usr/share/ibus-hangul/setup/main.py", line 206, in <module>
:    Setup(bus).run()
:  File "/usr/share/ibus-hangul/setup/main.py", line 109, in __init__
:    self.__window.set_icon_from_file(icon_file)
:GError: Failed to open file '/usr/share/ibus-hangul/icons/ibus-hangul.svg': No such file or directory
:
:Local variables in innermost frame:
:model: <gtk.ListStore object at 0x221d2d0 (GtkListStore at 0x1f7c9c0)>
:ui_file: '/usr/share/ibus-hangul/setup/setup.ui'
:pipe: <subprocess.Popen object at 0x2249190>
:keylist_str: 'Hangul_Hanja,F9'
:column: <gtk.TreeViewColumn object at 0x221d370 (GtkTreeViewColumn at 0x1cf5550)>
:items: ['']
:button: <gtk.Button object at 0x221d320 (GtkButton at 0x1cf5250)>
:list: ['2\tDubeolsik', '2y\tDubeolsik Yetgeul', '39\tSebeolsik 390', '3f\tSebeolsik Final', '3s\tSebeolsik Noshift', '3y\tSebeolsik Yetgeul', '32\tSebeolsik Dubeol Layout', 'ro\tRomaja', 'ahn\tAhnmatae', '']
:icon_file: '/usr/share/ibus-hangul/icons/ibus-hangul.svg'
:bus: <Bus object at 0x21e9e10 (PYIBusBus at 0x1eacc00)>
:self: <__main__.Setup instance at 0x2120f80>
:current: '2'
:i: 'F9'
:notebook: <gtk.Notebook object at 0x221d1e0 (GtkNotebook at 0x229e020)>
:renderer: <gtk.CellRendererText object at 0x221d3c0 (GtkCellRendererText at 0x22bf170)>
:word_commit: False
:line: ''
:auto_reorder: True

comment:
:I attempted to open the application.
:The system was otherwise idle.

smolt_data:
:
:
:General
:=================================
:UUID: 816204ce-9831-45ff-b19e-9d391751d704
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4804.93
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Quad CPU    Q6600  @ 2.40GHz
:CPU Stepping: 11
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 4
:CPU Speed: 2403
:System Memory: 7967
:System Swap: 10015
:Vendor: MICRO-STAR INTERNATIONAL CO.,LTD
:System: MS-7360 1.0
:Form factor: Desktop
:Kernel: 3.3.0-0.rc5.git3.1.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10688:5218:29536) pci, None, HOST/PCI, G33/P35 Neo
:(32902:10689:32902:0) pci, pcieport, PCI/PCI, 82G33/G31/P35/P31 Express PCI Express Root Port
:(4523:24865:4523:24865) pci, pata_marvell, STORAGE, 88SE6121 SATA II Controller
:(32902:10544:5218:29536) pci, i801_smbus, SERIAL, G33/P35 Neo
:(32902:10529:5218:29536) pci, ata_piix, STORAGE, G33/P35 Neo
:(32902:10520:5218:29536) pci, None, PCI/ISA, G33/P35 Neo
:(32902:10534:5218:29536) pci, ata_piix, STORAGE, G33/P35 Neo
:(32902:9294:5218:29536) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(32902:10548:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(32902:10553:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(32902:10550:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(32902:10554:5218:29536) pci, ehci_hcd, USB, G33/P35 Neo
:(32902:10556:5218:29536) pci, ehci_hcd, USB, G33/P35 Neo
:(4354:11:4354:67) pci, snd_ctxfi, MULTIMEDIA, X-Fi Titanium series [EMU20k2]
:(32902:10564:5218:29536) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10560:5218:29536) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:5218:29536) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10570:5218:29536) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 6
:(32902:10551:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(32902:10552:5218:29536) pci, uhci_hcd, USB, G33/P35 Neo
:(4318:3051:6510:2149) pci, snd_hda_intel, MULTIMEDIA, GF104 High Definition Audio Controller
:(4318:3618:6510:2149) pci, nouveau, VIDEO, GF104 [GeForce GTX 460]
:(4332:33128:5218:13836) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_quad-lv_root / ext4 4096 4096 13092026 11547420 11416370 3276800 3141658 3141658
:/dev/sda2 /boot ext4 1024 1024 508745 431966 406366 128016 127781 127781
:/dev/mapper/vg_quad-lv_home /home ext4 4096 4096 32992146 32300482 30648566 8265728 8262241 8262241
:/dev/sdb1 WITHHELD fuseblk 4096 4096 244189951 169145388 169145388 676712624 676619483 676619483
:
Comment 1 Joseph Cordero 2012-03-04 20:19:31 EST
I tied to open this again, and again it failed.
I removed it from my system. This is the korean portion. I dont need this specific item.
I hope submitting this will assist with the on the internationalization.


Package: ibus-hangul-1.4.0-3.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 2 Daiki Ueno 2012-03-04 20:47:48 EST
(In reply to comment #1)
> I tied to open this again, and again it failed.
> I removed it from my system. This is the korean portion. I dont need this
> specific item.
> I hope submitting this will assist with the on the internationalization.

Yeah, thanks for submitting this.  Since the upstream has recently changed the icon handling, repackaging the latest git master will fix this issue too.
Comment 3 Fedora Update System 2012-03-04 23:42:32 EST
ibus-hangul-1.4.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-hangul-1.4.0-4.fc16
Comment 4 Fedora Update System 2012-03-04 23:42:41 EST
ibus-hangul-1.4.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ibus-hangul-1.4.0-4.fc17
Comment 5 Fedora Update System 2012-03-04 23:42:50 EST
ibus-hangul-1.4.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-hangul-1.4.0-4.fc15
Comment 6 Fedora Update System 2012-03-05 15:55:35 EST
Package ibus-hangul-1.4.0-4.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-hangul-1.4.0-4.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2856/ibus-hangul-1.4.0-4.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-03-29 04:54:44 EDT
ibus-hangul-1.4.0-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/ibus-hangul-1.4.0-5.fc16
Comment 8 Fedora Update System 2012-03-29 04:54:53 EDT
ibus-hangul-1.4.0-5.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-hangul-1.4.0-5.fc15
Comment 9 Fedora Update System 2012-04-10 23:52:38 EDT
ibus-hangul-1.4.0-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-04-10 23:57:15 EDT
ibus-hangul-1.4.0-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-04-11 13:04:04 EDT
ibus-hangul-1.4.0-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2012-04-11 13:08:27 EDT
ibus-hangul-1.4.0-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.