Bug 799808 - Updated gperftools breaks gearmand (so.0 required, so.4 provided)
Summary: Updated gperftools breaks gearmand (so.0 required, so.4 provided)
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gperftools
Version: 16
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-05 05:42 UTC by Drew F
Modified: 2012-05-02 20:32 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-03-17 23:58:54 UTC


Attachments (Terms of Use)

Description Drew F 2012-03-05 05:42:07 UTC
Description of problem:
Updating gperftools prevents gearmand from being updated or installed.

Version-Release number of selected component (if applicable):
gperftools-libs-2.0-4.fc16.i686, gearmand.x86_64 0:0.23-1.fc16

How reproducible:
Always

Steps to Reproduce:
1. yum install gearmand
  
Actual results:
$> yum install gearmand
Loaded plugins: langpacks, presto, refresh-packagekit
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package gearmand.x86_64 0:0.23-1.fc16 will be installed
--> Processing Dependency: libmemcached.so.7()(64bit) for package: gearmand-0.23-1.fc16.x86_64
--> Processing Dependency: libboost_program_options-mt.so.1.47.0()(64bit) for package: gearmand-0.23-1.fc16.x86_64
--> Processing Dependency: libgearman.so.6()(64bit) for package: gearmand-0.23-1.fc16.x86_64
--> Processing Dependency: libtcmalloc.so.0()(64bit) for package: gearmand-0.23-1.fc16.x86_64
Package google-perftools-libs-1.9.1-1.fc16.x86_64 is obsoleted by gperftools-libs-2.0-4.fc16.i686 which is already installed
--> Running transaction check
---> Package boost-program-options.x86_64 0:1.47.0-6.fc16 will be installed
---> Package gearmand.x86_64 0:0.23-1.fc16 will be installed
--> Processing Dependency: libtcmalloc.so.0()(64bit) for package: gearmand-0.23-1.fc16.x86_64
Package google-perftools-libs-1.9.1-1.fc16.x86_64 is obsoleted by gperftools-libs-2.0-4.fc16.i686 which is already installed
---> Package libgearman.x86_64 0:0.23-1.fc16 will be installed
---> Package libmemcached.x86_64 0:0.49-1.fc16 will be installed
--> Finished Dependency Resolution
Error: Package: gearmand-0.23-1.fc16.x86_64 (fedora)
           Requires: libtcmalloc.so.0()(64bit)
           Available: google-perftools-1.8-1.fc16.x86_64 (fedora)
               libtcmalloc.so.0()(64bit)
           Available: google-perftools-libs-1.9.1-1.fc16.x86_64 (updates)
               libtcmalloc.so.0()(64bit)
           Available: google-perftools-1.9.1-1.fc16.x86_64 (updates)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Expected results:
Successful install of gearmand

Additional info:
Seems to be a similar problem to #791150.

Comment 1 Fedora Update System 2012-03-07 20:58:39 UTC
gearmand-0.14-4.fc15.1 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gearmand-0.14-4.fc15.1

Comment 2 Fedora Update System 2012-03-07 20:59:06 UTC
gearmand-0.23-1.fc16.1 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gearmand-0.23-1.fc16.1

Comment 3 Fedora Update System 2012-03-08 03:56:42 UTC
Package gearmand-0.14-4.fc15.1:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gearmand-0.14-4.fc15.1'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3282/gearmand-0.14-4.fc15.1
then log in and leave karma (feedback).

Comment 4 Drew F 2012-03-09 20:20:49 UTC
Feedback left for FC15 and FC16 gearmand packages. Both installations working as expected.

Comment 5 Fedora Update System 2012-03-17 23:58:54 UTC
gearmand-0.23-1.fc16.1 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 6 Fedora Update System 2012-03-18 00:03:58 UTC
gearmand-0.14-4.fc15.1 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Mike C. 2012-04-03 17:40:14 UTC
This problem still exists in the EPEL repo. Should I open another ticket against EPEL?

$> yum install gearmand
...
Error: Package: gearmand-0.14-3.el6.i686 (epel)
           Requires: libtcmalloc.so.0

Comment 8 Tom "spot" Callaway 2012-04-04 14:20:08 UTC
No need. I'll take care of that right now.

Comment 9 Fedora Update System 2012-04-04 14:33:21 UTC
gearmand-0.14-3.el6.1 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/gearmand-0.14-3.el6.1

Comment 10 Fedora Update System 2012-05-02 20:32:04 UTC
gearmand-0.14-3.el6.2 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.