Bug 799813 - RFE: Skynet pretty topic URLs
RFE: Skynet pretty topic URLs
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.x
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lee Newson
Joshua Wulf
:
Depends On:
Blocks: 799821
  Show dependency treegraph
 
Reported: 2012-03-05 01:15 EST by Lee Newson
Modified: 2014-10-19 19:00 EDT (History)
2 users (show)

See Also:
Fixed In Version: 0.22.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-01 04:05:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2012-03-05 01:15:05 EST
Now that Skynet has meaningful URLs, the processor should also adopt the same approach.

This also means making the ID components in sections, etc... to follow the same guidelines because building by html uses the ID attribute rather then the file name.
Comment 1 Lee Newson 2012-03-05 01:17:22 EST
See Bug #783356 for more details.
Comment 2 Lee Newson 2012-03-09 00:38:41 EST
Added as at 0.22.0 with a minor fix in 0.22.1.

The processor will now process the links in the same way as Skynet does. However in the case that a topic is included twice in a content spec then it will fall back to the same logic previous applied by appending the "-<COUNT>" message.

One change that was made to the builder is previously any topics that had duplicates always got appended with the "-<COUNT>". Now however the first one will remain the same and duplicates will be appended. ie:

Before:

Duplicate of "Content Specification Processor [5690]" would become:
5690-1.xml
5690-2.xml

Now:

Duplicate of "Content Specification Processor [5690]" would become:
Content_Specification_Processor.xml
Content_Specification_Processor-1.xml
Comment 3 Joshua Wulf 2012-05-01 04:05:18 EDT
Verified in cspclient-0.23.2-1.

Note You need to log in before you can comment on or make changes to this bug.