Bug 799859 - [lvmetad] VGs not visible on other nodes in cluster
Summary: [lvmetad] VGs not visible on other nodes in cluster
Status: CLOSED DUPLICATE of bug 814779
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: lvm2   
(Show other bugs)
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Rockai
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-05 09:34 UTC by Marian Csontos
Modified: 2012-07-18 10:43 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-18 10:43:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Marian Csontos 2012-03-05 09:34:16 UTC
Description of problem:
lvmetad does not work in cluster - created VGs are not visible on other nodes in cluster

Version-Release number of selected component (if applicable):
lvm-2.02.95-0.64.el6 (mostly the same as lvm2-2.02.94)

How reproducible:
100%

Steps to Reproduce:
1. Create VG on one node of cluster
2. Create LV on any node of the cluster
  
Actual results:
VG is not found

Expected results:
VG should be visible to all nodes

Additional info:

When creating LV on same node where VG was created it results in message like this:

>   Error locking on node node03: Volume group for uuid not found: lVSWIwXwjd9LIkejrB1gX6OKdf43SvosjaBNrG4MhCXZQp9NEyOSroNlfUI9KitQ
>   Error locking on node node02: Volume group for uuid not found: lVSWIwXwjd9LIkejrB1gX6OKdf43SvosjaBNrG4MhCXZQp9NEyOSroNlfUI9KitQ
>   Failed to activate new LV.

When creating LV on another node it results in:

>   Volume group "centipede" not found

Comment 2 Alasdair Kergon 2012-03-06 03:43:56 UTC
This is outside the scope of the first release.

Comment 4 RHEL Product and Program Management 2012-07-10 08:25:55 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2012-07-10 23:56:49 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 6 Peter Rajnoha 2012-07-18 10:43:27 UTC

*** This bug has been marked as a duplicate of bug 814779 ***


Note You need to log in before you can comment on or make changes to this bug.