Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
lvmetad does not work in cluster - created VGs are not visible on other nodes in cluster
Version-Release number of selected component (if applicable):
lvm-2.02.95-0.64.el6 (mostly the same as lvm2-2.02.94)
How reproducible:
100%
Steps to Reproduce:
1. Create VG on one node of cluster
2. Create LV on any node of the cluster
Actual results:
VG is not found
Expected results:
VG should be visible to all nodes
Additional info:
When creating LV on same node where VG was created it results in message like this:
> Error locking on node node03: Volume group for uuid not found: lVSWIwXwjd9LIkejrB1gX6OKdf43SvosjaBNrG4MhCXZQp9NEyOSroNlfUI9KitQ
> Error locking on node node02: Volume group for uuid not found: lVSWIwXwjd9LIkejrB1gX6OKdf43SvosjaBNrG4MhCXZQp9NEyOSroNlfUI9KitQ
> Failed to activate new LV.
When creating LV on another node it results in:
> Volume group "centipede" not found
Comment 4RHEL Program Management
2012-07-10 08:25:55 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5RHEL Program Management
2012-07-10 23:56:49 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development. This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.