Bug 799909 - Can't connect to '/var/run/abrt/abrt.socket': Connection refused
Summary: Can't connect to '/var/run/abrt/abrt.socket': Connection refused
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jiri Moskovcak
QA Contact: Branislav Náter
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-05 11:56 UTC by Michal Nowak
Modified: 2015-02-01 22:55 UTC (History)
7 users (show)

Fixed In Version: libreport-2.0.9-9.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:53:06 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0290 normal SHIPPED_LIVE abrt, libreport and btparser bug fix and enhancement update 2013-02-20 20:55:47 UTC

Description Michal Nowak 2012-03-05 11:56:43 UTC
Description of problem:

When attempted to remove non-existing crash dir I got:

# abrt-cli rm sdfsdf
'sdfsdf' does not exist
Can't connect to '/var/run/abrt/abrt.socket': Connection refused

I find the last line confusing, the last-but-one alone should be OK.

Version-Release number of selected component (if applicable):

abrt-2.0.8-1.el6.x86_64
libreport-2.0.9-1.el6.x86_64

How reproducible:

always

Comment 2 Jiri Moskovcak 2012-03-06 15:33:38 UTC
abrtd is not running, but I agree that the message is confusing

Comment 3 Michal Nowak 2012-03-07 06:41:31 UTC
Just a note that I was able to remove (real) $crash_dir that time.

Comment 4 Jiri Moskovcak 2012-04-05 13:28:03 UTC
The message appears only if the daemon is stopped, so I think it's not so critical, but fixing it might break things -> proposing for 6.4

Comment 6 RHEL Program Management 2012-07-10 08:32:09 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 7 RHEL Program Management 2012-07-10 23:02:51 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 9 Jiri Moskovcak 2012-08-17 08:45:49 UTC
commit f49eebc43bb248e3ed9c6222f9fbd84b4ab3a242
Author: Jiri Moskovcak <jmoskovc@redhat.com>
Date:   Mon Aug 6 16:43:23 2012 +0200

    don't try to delete dump dir which doesn't exist rhbz#799909

Comment 11 Branislav Náter 2012-12-14 15:47:33 UTC
Fix has been verified on abrt-2.0.8-9.el6, libreport-2.0.9-11 packages versions.

No confusing "...Connection refused" messages are shown during crash dir removal.

# rpm -q abrt
abrt-2.0.8-9.el6
# rpm -q libreport
libreport-2.0.9-11.el6
# service abrtd status
abrtd is stopped
# abrt-cli rm somedir
'somedir' does not exist
#

Comment 12 Jiri Moskovcak 2013-01-24 14:25:02 UTC
Cause
    Confusing error message appeared when trying to remove non existing problem directory
Consequence
    Confused user
Fix
    Don't show the "Connection refused" message when trying to delete non existing problem
Result
    Only message about non existing directory is shown, so user is not confused by this message

Comment 13 errata-xmlrpc 2013-02-21 07:53:06 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html


Note You need to log in before you can comment on or make changes to this bug.