Bug 799921 - v7 1.5 R7 may trace-back on older /etc/v7.xml environment file.
v7 1.5 R7 may trace-back on older /etc/v7.xml environment file.
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (harness) (Show other bugs)
1.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Petr Beňas
:
Depends On:
Blocks: 767775
  Show dependency treegraph
 
Reported: 2012-03-05 07:27 EST by Greg Nichols
Modified: 2015-01-04 18:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
no tech note needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 17:37:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Nichols 2012-03-05 07:27:19 EST
Description of problem:

If v7 1.5 R7 is run on an older environment file, it produces a traceback:

removing V7 results...
[root@hp-xw6400-02 ~]# v7 plan
found interface for udisks
found device file /dev/sdb
Traceback (most recent call last):
  File "/usr/bin/v7", line 45, in <module>
    success = v7.do(args)
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 192, in do
    result = self.commands[self.command]()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 321, in doPlan
    self.doDiscover()
  File "/usr/share/v7/lib/v7/hardwaretest.py", line 237, in doDiscover
    certificationDocument.load(self.environment.getCertificationPath())
  File "/usr/share/v7/lib/v7/documentbase.py", line 251, in load
    file = open(filename, "r")
IOError: [Errno 21] Is a directory: u'/var/v7/'

  
Workaround: delete the environment file: /etc/v7.xml before running v7 plan after installing R7.
Comment 4 Petr Beňas 2012-03-29 04:55:46 EDT
Reproduced in v7-1.5-7.el6.noarch and verified in v7-1.5-8.el6.noarch.
Comment 5 Caspar Zhang 2012-06-04 03:55:10 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
no tech note needed.
Comment 7 errata-xmlrpc 2012-06-05 17:37:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0711.html

Note You need to log in before you can comment on or make changes to this bug.