Bug 799968 - Policy for SSSD should allow CAP_SYS_RESOURCE
Policy for SSSD should allow CAP_SYS_RESOURCE
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: selinux-policy (Show other bugs)
6.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks: 799929 815154 834621
  Show dependency treegraph
 
Reported: 2012-03-05 09:14 EST by Stephen Gallagher
Modified: 2012-10-16 07:03 EDT (History)
2 users (show)

See Also:
Fixed In Version: selinux-policy-3.7.19-139.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 834621 (view as bug list)
Environment:
Last Closed: 2012-06-20 08:31:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Gallagher 2012-03-05 09:14:26 EST
Description of problem:
SSSD sometimes handles very busy systems with more than 4k processes running simultaneously. We need the CAP_SYS_RESOURCE privilege to request a higher open file-descriptor limit to achieve this.

Version-Release number of selected component (if applicable):
selinux-policy-3.7.19-138.el6

How reproducible:
Every time

Steps to Reproduce:
1. Start sssd-1.8.0-11.el6
2. See AVC about SSSD requesting more file descriptors
  
Actual results:
SSSD is denied privileges to request 8k descriptors.

Expected results:
SSSD should be allowed to perform this action.

Additional info:
Internally, we handle the denial gracefully and just set our limits to the available maximum.
Comment 2 Miroslav Grepl 2012-03-06 02:23:07 EST
Fixed in selinux-policy-3.7.19-139.el6
Comment 6 errata-xmlrpc 2012-06-20 08:31:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0780.html

Note You need to log in before you can comment on or make changes to this bug.