Bug 799981 - Push all button visibility conditions
Push all button visibility conditions
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: 1.0.2
: ---
Assigned To: Imre Farkas
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 09:38 EST by Petr Blaho
Modified: 2012-12-04 09:57 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The 'Push all' button was visible to users even if was no image existed for the push. This bug fix updates Conductor so that the 'Push all' button is not visible unless there is an existing image. The button is also not visible after all images are deleted.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:57:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Blaho 2012-03-05 09:38:43 EST
Description of problem:
Push all button is now visible on Image page if there is latest build even if that latest build have no target images.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. create new image
2. build image for provider
3. see push all button
4. delete image for provider
5. still see push all button even if there is no image to push
  
Actual results:
still see push all button even if there is no image to push

Expected results:
push all button should disapear

Additional info:
When displaying push all button one should check not only for latest build for selected image but also if that build has any target images built (ready to  push)
Comment 1 Hugh Brock 2012-03-06 10:00:32 EST
What happens when you press the button?
Comment 2 Petr Blaho 2012-03-06 10:03:15 EST
From the user point of view nothing - only page is reloaded.
Comment 3 Imre Farkas 2012-03-07 10:08:54 EST
Patch has been posted: https://fedorahosted.org/pipermail/aeolus-devel/2012-March/009450.html
Comment 4 Imre Farkas 2012-03-09 05:34:54 EST
This issue has been fixed. Please verify the commit e562208b3071344971214ec7a72f461f9a198628
Comment 5 Steve Linabery 2012-04-12 17:37:27 EDT
e562208b3071344971214ec7a72f461f9a198628 is only in master branch as of this writing.
Comment 8 pushpesh sharma 2012-09-20 06:16:32 EDT
-Push all button is not visible till atleast a single provider has completed image building process.
-A Provider now has a builed image.Pressing "push all" button after this results in pushing for that provider only. 
-Deletion of image after it is pushed,results in disappeared "Push all" button.
  

Above observation satisfy the expectation from the fix.Marking as verified.

[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch
Comment 11 errata-xmlrpc 2012-12-04 09:57:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.