Bug 79999 - xinetd IPv6 clean-up
xinetd IPv6 clean-up
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: xinetd (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-18 11:47 EST by Pekka Savola
Modified: 2007-04-18 12:49 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-17 11:45:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2002-12-18 11:47:19 EST
In #49621 and like, hacks were added to xinetd (build two versions), because
xinetd offered only on/off compile-time IPv6 support.

In 2.3.7 it has been improved, and can be controlled by "flags = IPv6" and the like.

Therefore,

 1) now identical xinetd-ipv6 binary can be removed and the build process
cleaned up a bit
 2) init.d/xinetd can be cleaned up a bit, like:

diff -uN xinetd~ xinetd
--- xinetd~	Wed Dec 18 18:34:41 2002
+++ xinetd	Wed Dec 18 18:34:41 2002
@@ -39,11 +39,7 @@
 
 RETVAL=0
 
-if [ "$NETWORKING_IPV6" = "yes" ] && [ -x /usr/sbin/xinetd-ipv6 ]; then
-    prog="xinetd-ipv6"
-else
-    prog="xinetd"
-fi
+prog="xinetd"
 
 start(){
     echo -n $"Starting $prog: "
Comment 1 Jay Fenlason 2003-01-17 11:45:51 EST
Try xinetd-2.3.10-1, now in rawhide

Note You need to log in before you can comment on or make changes to this bug.