Bug 799992 - Creating kickstart profile ends with ISE
Creating kickstart profile ends with ISE
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.7
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space17
  Show dependency treegraph
 
Reported: 2012-03-05 10:05 EST by Matej Kollar
Modified: 2015-07-26 18:20 EDT (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-1.8.3-1 spacewalk-java-1.7.54-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 04:55:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matej Kollar 2012-03-05 10:05:12 EST
Description of problem:
-----------------------

  Creating kickstart profile via WebUI ends with ISE. 

Version-Release number of selected component (if applicable):
-------------------------------------------------------------

  Spacewalk release 1.7 nightly

How reproducible:
-----------------

  always/deterministic

Steps to Reproduce:
-------------------

  1. Set up Spacewalk
     1.5. Activate
  2. Sync channel with kickstart trees (e.g. rhel-x86_64-server-6)
  3. Create new kickstart profile
  
Actual results:
---------------

  After third step (root password) ISE occurs.

Expected results:
-----------------

  Kickstart profile is created.


Additional info:
----------------

  Following traceback occurs in /var/log/tomcat6/catalina.out on ISE

  > javax.servlet.ServletException: java.lang.reflect.InvocationTargetException
  >         at org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:520)
  >         at org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:427)
  >         at org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:228)
  >         at com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:99)
  >         at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1913)
  ...
  > Caused by: java.lang.reflect.InvocationTargetException
  >         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  >         at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
  >         at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  >         at java.lang.reflect.Method.invoke(Method.java:616)
  ...
  > Caused by: java.lang.NullPointerException
  >         at com.redhat.rhn.manager.kickstart.KickstartFormatter.generateActKeyTokens(KickstartFormatter.java:854)
  >         at com.redhat.rhn.manager.kickstart.KickstartFormatter.getRhnPost(KickstartFormatter.java:668)
  >         at com.redhat.rhn.manager.kickstart.KickstartFormatter.getFileData(KickstartFormatter.java:286)
  >         at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:359)
  >         at com.redhat.rhn.domain.kickstart.KickstartFactory.saveKickstartData(KickstartFactory.java:393)
  ...

  It seemed like cobbler issue, as when calling "cobbler sync" from command line exception occured:

  ...
  > Exception occured: <class 'cobbler.cexceptions.CX'>
  > Exception value: 'Could not find files matching /usr/lib/syslinux/pxelinux.0'
  > Exception Info:
  >   File "/usr/lib/python2.6/site-packages/cobbler/remote.py", line 95, in run
  >     rc = self._run(self)
  >    File "/usr/lib/python2.6/site-packages/cobbler/remote.py", line 184, in runner
  >     return self.remote.api.sync(self.options.get("verbose",False),logger=self.logger)
  >    File "/usr/lib/python2.6/site-packages/cobbler/api.py", line 611, in sync
  >     return sync.run()
  >    File "/usr/lib/python2.6/site-packages/cobbler/action_sync.py", line 113, in run
  >     self.pxegen.copy_bootloaders()
  >    File "/usr/lib/python2.6/site-packages/cobbler/pxegen.py", line 101, in copy_bootloaders
  >     dst, api=self.api, cache=False, logger=self.logger)
  >    File "/usr/lib/python2.6/site-packages/cobbler/utils.py", line 1173, in copyfile_pattern
  >     raise CX(_("Could not find files matching %s") % pattern)
  > 
  > !!! TASK FAILED !!!

  This was however resolved by installing syslinux

  # yum install syslinux

  but creating kickstart was still not possible.

  Versions of "related" packages
  # rpm -qa | grep spacewalk
  spacewalk-doc-indexes-1.1.1-1.el6.noarch
  spacewalk-config-1.7.2-1.el6.noarch
  spacewalk-html-1.7.26-1.el6.noarch
  spacewalk-backend-applet-1.7.36-1.el6.noarch
  spacewalk-pxt-1.7.26-1.el6.noarch
  spacewalk-backend-tools-1.7.36-1.el6.noarch
  spacewalk-slf4j-1.6.1-1.el6.noarch
  spacewalk-setup-jabberd-1.6.5-1.el6.noarch
  spacewalk-backend-app-1.7.36-1.el6.noarch
  spacewalk-backend-package-push-server-1.7.36-1.el6.noarch
  spacewalk-sniglets-1.7.26-1.el6.noarch
  spacewalk-java-lib-1.7.50-1.el6.noarch
  spacewalk-schema-diff-0.15-1.el5sat.noarch
  spacewalk-backend-libs-1.7.36-1.el6.noarch
  spacewalk-jpp-workaround-1.0.1-1.el6.noarch
  spacewalk-certs-tools-1.7.2-1.el6.noarch
  spacewalk-base-minimal-1.7.26-1.el6.noarch
  spacewalk-backend-sql-1.7.36-1.el6.noarch
  spacewalk-backend-xmlrpc-1.7.36-1.el6.noarch
  spacewalk-backend-config-files-1.7.36-1.el6.noarch
  spacewalk-backend-iss-1.7.36-1.el6.noarch
  spacewalk-grail-1.7.26-1.el6.noarch
  spacewalk-setup-1.7.8-1.el6.noarch
  spacewalk-java-1.7.50-1.el6.noarch
  spacewalk-backend-sql-oracle-1.7.36-1.el6.noarch
  spacewalk-java-oracle-1.7.50-1.el6.noarch
  spacewalk-backend-config-files-common-1.7.36-1.el6.noarch
  spacewalk-branding-1.7.1-1.el6.noarch
  spacewalk-backend-config-files-tool-1.7.36-1.el6.noarch
  spacewalk-backend-xp-1.7.36-1.el6.noarch
  spacewalk-base-1.7.26-1.el6.noarch
  spacewalk-monitoring-selinux-1.7.2-1.el6.noarch
  spacewalk-selinux-1.7.2-1.el6.noarch
  spacewalk-common-1.7.2-1.el6.noarch
  spacewalk-backend-xml-export-libs-1.7.36-1.el6.noarch
  spacewalk-taskomatic-1.7.50-1.el6.noarch
  spacewalk-monitoring-1.4.1-1.el6.noarch
  spacewalk-oracle-1.7.2-1.el6.noarch
  spacewalk-search-1.7.2-1.el6.noarch
  spacewalk-backend-1.7.36-1.el6.noarch
  spacewalk-backend-server-1.7.36-1.el6.noarch
  spacewalk-backend-iss-export-1.7.36-1.el6.noarch
  spacewalk-admin-1.7.3-1.el6.noarch
  spacewalk-schema-1.7.54-1.el6.noarch
  spacewalk-java-config-1.7.50-1.el6.noarch
Comment 1 Tomas Lestach 2012-03-06 03:45:05 EST
spacewalk.git: 3771ba9cd97164a46d2ba0d77d8e982faa6e6bef
Comment 3 Jan Pazdziora 2012-03-07 04:55:08 EST
Spacewalk 1.7 has been released:

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes17

Note You need to log in before you can comment on or make changes to this bug.