Bug 800008 - FTBFS: rubygem-rspec-rails-2.6.1-3.el6
FTBFS: rubygem-rspec-rails-2.6.1-3.el6
Status: CLOSED ERRATA
Product: CloudForms Common
Classification: Red Hat
Component: rubygem-rspec-rails (Show other bugs)
1.0.0
All Linux
medium Severity medium
: rc
: ---
Assigned To: Mike Orazi
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 10:32 EST by John Eckersberg
Modified: 2012-05-15 15:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-15 15:22:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Eckersberg 2012-03-05 10:32:27 EST
rubygem-rspec-rails fails to rebuild from source.  See build failure at https://brewweb.devel.redhat.com/taskinfo?taskID=4104052 for details.
Comment 3 Jay Turner 2012-04-25 21:14:34 EDT
Not really sure what is going on here.  Sometimes the rebuild succeeds, sometimes it fails.  In fact building the package back-to-back-to-back sometimes demonstrates alternating success and failure.  Seems that all of the failures are from the same 2 tests:

Failed examples:

rspec ./spec/rspec/rails/matchers/be_a_new_spec.rb:69 # be_a_new matcher#with right class and new record no attributes same fails
rspec ./spec/rspec/rails/matchers/be_a_new_spec.rb:115 # be_a_new matcher#with wrong class and existing record no attributes same fails

Not sure what that really means and if there is something we need to look into.  Bouncing back to Assigned to get a review of this issue.
Comment 4 James Laska 2012-04-26 08:30:47 EDT
Eck directed me to an upstream patch that resolves rpm rebuild failures (https://github.com/rspec/rspec-rails/commit/e5938b8d37e00439f83a2fb3f4b8d2ceae29f7f6).  I locally built a new rubygem-rspec-rails with this patch, and it consistently builds in brew [1] without error

Is this patch safe to include in a new rubygem-rspec-rails build?

[1] https://brewweb.devel.redhat.com/taskinfo?taskID=4345618
Comment 5 John Eckersberg 2012-04-26 10:18:21 EDT
The patch as it exists in upstream throws some warnings due to unescaped regex strings.  I've fixed those and built the result here:

https://brewweb.devel.redhat.com/buildinfo?buildID=211648
Comment 7 James Laska 2012-04-26 12:17:08 EDT
I'm no longer able to reproduce the FTBFS failure
Comment 8 errata-xmlrpc 2012-05-15 15:22:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0627.html

Note You need to log in before you can comment on or make changes to this bug.