Bug 80009 - Bugzilla's new forced serialization is disruptive to those who use bugzilla in a parallelized fashion
Bugzilla's new forced serialization is disruptive to those who use bugzilla i...
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.17
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-12-18 14:06 EST by Mike A. Harris
Modified: 2007-04-18 12:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-23 13:17:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike A. Harris 2002-12-18 14:06:33 EST
When updating bug reports using the new bugzilla, I've found that once I
submit a bug report, some new bug report comes up that is unrelated to the
bug report I just submitted.  I initially thought this was some weird random
bug in bugzilla and discussed it with Dave, who explained it is a bugzilla
feature which goes to the next bug in your list.

I personally find this "feature" to be extremely inconvenient and intrusive
to how I personally use bugzilla.  I do not have a use for clicking on one
bug report, and then going through all of them one at a time in sequence, and
bugzilla forcing this upon me is extremely confusing.

I recognize that everyone will have their own personal preferences, and that
some people may like this new feature for one reason or another.  It may be
a big help to some, however it is a very big hindrance to me personally.

A feature like this really should be a per-user option that one can enable
or disable in preferences or somesuch, and not forced on to all users.

Please realize that different types of software and different development
practices have different patterns.  And different developers also have
different patterns how they do things.  It is not useful to me at all to ever
go through XFree86 bug reports one at a time automatically.

The new bugzilla, without a doubt is awesome.  This one "feature" though is
really setting me back and losing bug reports, getting sidetracked on other
issues than what I am trying to focus on, etc.

Here is how I use bugzilla, and how I expect it to work in order to be the
most useful to me for XFree86 maintenance.  I use mozilla as my web browser
and make extensive use of tabbed browsing.  I open all tabs up in the
background always, so that the page can load up behind the scenes, whilst I
do other things in the current window, or elect to manually choose another
window.  I find this the most efficient, as then I am not staring blankly and
idly at a browser window waiting for it to pop up and finish loading. I
open up one tab on the left, and bring up a bug list on it from one of my
many preset bookmark queries in my Mozilla bugzilla folder on my personal
toolbar.  Once that list is open, I middle click on any bug IDs that are
interesting or which I need to look at.  I may look at one or two, or may
pop up an entire list of them each in the background and in their own tab.
I go through these related reports, duping, adding cross references, etc.
as needed, and trying to deal with issues that are identical, or all related
to one single area of XFree86 at a time, such as "xfs", "fonts", "radeon
driver", etc.  This is all in parallel as I use multiple tabs.

I generally leave those tabs open until I am done with them also, and sometimes
I update a report with some info, then plan on performing another operation
on the same bug immediately afterward, or not too long after.  While looking
at other bug reports, I sometimes want to update report 12345, then look at
4 others that are open, then add info to 12345 from the others, etc. and maybe
update them again, etc.

Bugzilla's current behaviour however when I update a report, forces me to
go to the next report in the list, which may or may not even be related to the
problem domain that I am investigating right now, but is just next serially in
the list.  For bugs that I've pre-opened that are actually chosen off a list
serially, what happens is I've already got the top 5-10 bugs in the list open,
I update one of them, bugzilla bumps the bug to the next one, and now I have
two copies of the same bug open.  I don't notice this as I don't sit and watch
bugzilla update a bug, I go to another tab and begin working on the next thing.
When I come back, now I have 2 bugs the same open, and end up in a big mess.

It is extremely frustrating, and is severely limiting my usage of bugzilla.
This new "feature" may indeed be a wonderful thing for people who use bugzilla
in a 'serial' nature, perhaps with a small number of bug reports, or with
packages that don't have many bug reports, but for me at least, working with
bugzilla with a large number of bug reports open in parallel, it is extremely
disruptive.

Please make bugzilla revert to the behaviour of the old bugzilla in not
auto-jumping to the next bug report, or else make it a user preference so that
both developers that view many bugs in parallel and developers that go through
bugs more serially can have a default setup that works well.
Comment 1 Phil Knirsch 2002-12-18 14:34:17 EST
AOL. Says it all. I was really confused after the first couple of instances (I
usually have multiple browser windows open, each on with 'his' bugzilla entry).

Please make it configurable at least.

Thanks,

Read ya, Phil
Comment 2 Michael K. Johnson 2002-12-18 14:48:30 EST
AOL.  I also use tabbed browsing and don't want my bug windows confused.
Comment 3 Brent Fox 2002-12-18 15:24:29 EST
I couldn't read that whole thing, but I like the old behavior better.
Comment 4 Havoc Pennington 2002-12-18 15:35:57 EST
Non-AOL, new behavior is way better for going through bug lists.

If we start using milestones and keywords appropriately, we should have many
meaningful queries that need to be gone through as a list. People just don't
have good queries or bug lists right now because we've lacked features such as
keywords.

e.g. going through all GinGinBlocker bugs assigned to me, going through all 
bugs without the Triaged keyword, going through all bugs assigned to me with
priority High, etc., those are all common operations.

there's a big "go back to bug XYZ" button when it goes to the next bug, after all.
Comment 5 Mike A. Harris 2002-12-18 16:28:53 EST
>Non-AOL, new behavior is way better for going through bug lists.

For you maybe.  Not for me.  I respect your preference, please also respect
mine.

>If we start using milestones and keywords appropriately, we should have many
>meaningful queries that need to be gone through as a list. People just don't
>have good queries or bug lists right now because we've lacked features such as
>keywords.

I very much do that already.  A given "milestone" is not something that
is useful information for me to query on, however bugzilla does and has
had the ability to do so for ages.  It just is not useful to me in that
way.  What is useful, is the milestone blocker/target info that gets
put on bug reports as our developmental process goes on.  Dr. Mike has
a status page CGI script which has been very instrumentally useful to
me during the last few phases of our development each release.

The habits and features that work well for one developer, with certain
projects, do not necessarily work well for all developers of all projects.

Forcing everyone to do things one single way because it works for one set
of people, is not the way to do things.  Being flexible, and allowing each
person to continue to benefit from bugzilla by not having to drastically
change the way they use it and throw out existing methods that work and work
well.  I have explained the way that I do things above.  That is what works
for me, and it is what I am willing to do.  I have many bookmarks and preformed
queries.  They're not stored in bugzilla itself as that is not something
I personally find useful.  They are stored as bookmarks in my web browser.
The premade bookmarks that I have, do what I want, and in a way that I want
it to work.

I work best with bugzilla by viewing bug reports in parallel.  Doing so in
series the way that it is set up right now, is not useful to me.

If bugzilla becomes unuseable for me, then I just simply wont use it
anymore.  Right now, all day long I am fighting with this stupid serialization
and it is driving me absolutely nuts.

In the short term, bugzilla should go back to the way it was before in
this regard, and in the long term, if this new "feature" is considered
useful by some developers, then it should be made an option as stated above.
That way you get to work serially in a way that makes you work most
effectively, and myself, mkj, bfox, pknirsh, and others get to work in
a manner that works best for us.  For me, that is viewing bugs in parallel,
and not one after the other in the same tab.



Comment 6 David Lawrence 2002-12-18 17:04:38 EST
4 AOL's to 1 Non-AOL. The AOL's win!!! 5 votes makes a democracy. Changing back
to old way until preferences can be made. 
Comment 7 David Lawrence 2002-12-23 13:17:41 EST
Opened a new RFE bug 80270 and added interested parties to cc list.

Note You need to log in before you can comment on or make changes to this bug.