Bug 800137 - xulrunner no longer provides directory required by other packages
xulrunner no longer provides directory required by other packages
Status: CLOSED DUPLICATE of bug 799042
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xulrunner (Show other bugs)
All All
unspecified Severity medium
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
Depends On:
  Show dependency treegraph
Reported: 2012-03-05 15:03 EST by Jay Denebeim
Modified: 2012-03-05 15:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2012-03-05 15:23:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jay Denebeim 2012-03-05 15:03:06 EST
Description of problem:
xulrunner up to at least version provided /usr/lib/mozilla/plugins  The current version 10.0.1-2.el5_8 does not provide that directory.  Nothing does.

This results in an error:

1:java-1.6.0-sun-plugin- ... has depsolving problems
Missing Dependency: /usr/lib/mozilla/plugins needed by ...

Yum update fails due to the depsolving failure.

Version-Release number of selected component (if applicable):
xulrunner 10.0.1-2.el5_8

How reproducible:
100% of the time

Steps to Reproduce:
1.rpm -q --whatprovides /usr/lib/mozilla/plugins
2.yum install xulrunner
3.rpm -q --whatprovides /usr/lib/mozilla/plugins
Actual results:
Only the first query contains xulrunner

Expected results:
Both rpm queries should contain xulrunner

Additional info:
The environment I'm working in has no provision for a local redhat based system to be connected to the internet.  This requires me to use mrepo to synchronize to rhn offsite and transfer deltas of the update repository to a local repository.  It is possible that this provision has been moved to another package, however I've been unable to locate any references on-line to that event and my repository does not have it.
Comment 1 Tomas Pelka 2012-03-05 15:23:06 EST

*** This bug has been marked as a duplicate of bug 799042 ***

Note You need to log in before you can comment on or make changes to this bug.