Bug 800144 - Rebuilding maven-surefire from scratch not possible
Rebuilding maven-surefire from scratch not possible
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: maven-surefire (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaromír Cápík
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-05 15:18 EST by David Walluck
Modified: 2016-01-31 20:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 13:50:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Walluck 2012-03-05 15:18:52 EST
Description of problem:

The actual patch line for 'Patch1: 0004-Surefire-2.12-bootstrap.patch' is commented out. It is conditional on '%bootstrap' being true.

It should be unconditionally included in the src.rpm. Only the application of the patch '%patch1' should be conditional.

Version-Release number of selected component (if applicable):

2.12-2

Actual results:

Patch is missing. Rebuilding from scratch is impossible.

Expected results:

Patch should be included in src.rpm.
Comment 1 Jaromír Cápík 2012-03-06 13:32:00 EST
Hi David.

Yes. You're right.
I did that because I believed everyone can download the sources from the repository, but it would be really better to fix that since the srpms are usually being imported to other distros and that could suppress any potential confusions.

Thanks for reporting.

Regards,
Jaromir.
Comment 2 Jaromír Cápík 2012-03-06 13:50:05 EST
Should be fixed now. Closing.

Note You need to log in before you can comment on or make changes to this bug.