Bug 800272 - soffice does not complain when running with wrong option
Summary: soffice does not complain when running with wrong option
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libreoffice
Version: 6.3
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-03-06 08:04 UTC by Tomas Pelka
Modified: 2012-06-20 12:53 UTC (History)
0 users

Fixed In Version: libreoffice-3.4.5.2-8.el6
Doc Type: Bug Fix
Doc Text:
Cause: No centralized list of what command line options are supported Consequence: Use of unsupported command line options is not indicated to the user Fix: Created a central point where all command line options are registered Result: Unknown command line options are reported as such
Clone Of:
Environment:
Last Closed: 2012-06-20 12:53:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:0798 normal SHIPPED_LIVE new packages: libreoffice 2012-06-19 21:00:52 UTC

Description Tomas Pelka 2012-03-06 08:04:44 UTC
Description of problem:
I would say soffice should complain when running with wrong parameter.

Version-Release number of selected component (if applicable):
libreoffice-3.4.5.2-5.el6

How reproducible:
100%

Steps to Reproduce:
1. run soffice --fwejhfskjhf
2.
3.
  
Actual results:
soffice just skip the wrong parameter silently and run, no objections

Expected results:
soffice should at least warn user that parameter is wrong

Additional info:

Comment 4 Caolan McNamara 2012-05-01 10:08:22 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: No centralized list of what command line options are supported

Consequence: Use of unsupported command line options is not indicated to the user

Fix: Created a central point where all command line options are registered

Result: Unknown command line options are reported as such

Comment 6 errata-xmlrpc 2012-06-20 12:53:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-0798.html


Note You need to log in before you can comment on or make changes to this bug.