Bug 800297 - OSAD through proxy is not picking events
OSAD through proxy is not picking events
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
541
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Milan Zazrivec
Martin Korbel
:
Depends On: 795680
Blocks: 790326 sat550-post-ga/sat550-test-blockers sat550-ipv6
  Show dependency treegraph
 
Reported: 2012-03-06 04:15 EST by Miroslav Suchý
Modified: 2012-10-23 06:03 EDT (History)
9 users (show)

See Also:
Fixed In Version: jabberd-2.2.8-19 spacewalk-setup-jabberd to 1.7.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 795680
Environment:
Last Closed: 2012-10-23 06:03:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Suchý 2012-03-06 04:15:23 EST
We should do that for RHN Satellite as well.

+++ This bug was initially created as a clone of Bug #795680 +++

Description of problem:

  While regisered to spacewalk proxy, osad is not picking events.

Version-Release number of selected component (if applicable):

  Proxy 1.6.5-1.el6
    # rpm -qa | grep proxy
    spacewalk-proxy-package-manager-1.6.5-1.el6.noarch
    spacewalk-proxy-installer-1.6.7-1.el6.noarch
    spacewalk-proxy-common-1.6.5-1.el6.noarch
    spacewalk-proxy-docs-1.1.1-1.el6.noarch
    spacewalk-proxy-broker-1.6.5-1.el6.noarch
    spacewalk-proxy-redirect-1.6.5-1.el6.noarch
    spacewalk-proxy-management-1.6.5-1.el6.noarch
    spacewalk-proxy-monitoring-1.6.1-1.el6.noarch
    spacewalk-proxy-html-1.1.1-1.el6.noarch
    spacewalk-proxy-selinux-1.1.1-1.el6.noarch
  (against Spacewalk 1.6, partly 1.7 ...)
    # rpm -qa | grep spacewalk
    spacewalk-selinux-1.6.2-1.el5
    spacewalk-backend-config-files-common-1.7.19-1.el5
    spacewalk-backend-package-push-server-1.7.19-1.el5
    spacewalk-java-config-1.6.102-1.el5
    spacewalk-setup-jabberd-1.6.5-1.el5
    spacewalk-monitoring-selinux-1.6.2-1.el5
    spacewalk-admin-1.6.3-1.el5
    spacewalk-search-1.6.8-1.el5
    spacewalk-common-1.5.1-1.el5
    spacewalk-backend-sql-1.7.19-1.el5
    spacewalk-backend-config-files-tool-1.7.19-1.el5
    spacewalk-branding-1.6.4-1.el5
    spacewalk-config-1.6.4-1.el5
    spacewalk-slf4j-1.6.1-1.el5
    spacewalk-pxt-1.6.38-1.el5
    spacewalk-backend-libs-1.7.19-1.el5
    spacewalk-grail-1.6.38-1.el5
    spacewalk-java-oracle-1.6.102-1.el5
    spacewalk-taskomatic-1.6.102-1.el5
    spacewalk-backend-server-1.7.19-1.el5
    spacewalk-backend-xmlrpc-1.7.19-1.el5
    spacewalk-backend-iss-1.7.19-1.el5
    spacewalk-backend-xp-1.7.19-1.el5
    spacewalk-repo-1.7-4.el5
    spacewalk-client-repo-1.7-4.el5
    spacewalk-java-lib-1.6.102-1.el5
    spacewalk-base-1.6.38-1.el5
    spacewalk-java-1.6.102-1.el5
    rh-tests-Spacewalk-Installer-Sanity-Yum-install-spacewalk-oracle-1.0-5
    spacewalk-backend-1.7.19-1.el5
    spacewalk-backend-xml-export-libs-1.7.19-1.el5
    spacewalk-backend-applet-1.7.19-1.el5
    spacewalk-backend-iss-export-1.7.19-1.el5
    spacewalk-certs-tools-1.6.7-1.el5
    spacewalk-base-minimal-1.6.38-1.el5
    spacewalk-doc-indexes-1.1.1-1.el5
    spacewalk-monitoring-1.4.1-1.el5
    spacewalk-schema-1.6.42-1.el5
    spacewalk-backend-sql-oracle-1.7.19-1.el5
    spacewalk-backend-config-files-1.7.19-1.el5
    spacewalk-html-1.6.38-1.el5
    spacewalk-setup-1.6.5-1.el5
    spacewalk-sniglets-1.6.38-1.el5
    spacewalk-oracle-1.5.1-1.el5
    spacewalk-backend-app-1.7.19-1.el5
    spacewalk-backend-tools-1.7.19-1.el5

  (on client we had osad-5.10.34-1.el5)

How reproducible:

  Always, deterministic

Steps to Reproduce:

  1.   Register client to proxy.
  1.5. (Make sure osad is running on client, you may want to restart osad if
       it was already running.)
  2.   Schedule event (e.g. enable monitoring and then schedule remote command).

Actual results:

  Nothing happens (I have been observing only for something more that
  half an hour, but I think that it does not work).

Expected results:

  Scheduled event is picked up.
  
Additional info:

  I have checked, that it works directly against spacewalk.

  When client is registered to proxy, OSA status is shown unknown.
  After (re)starting osad status changes to offline. Pinging system (via WebUI)
  adds info about last pinged, restarting osad typically removes this info.
  (So it seems that at least some information is propagated to spacewalk.)

  Looking at connection reveals, that osad process has open (TCP) connection
  to proxy, process c2s in particular. There does not seems to be any
  (persistent) connection directly to server. (But that may be ok(?))

  This was all run over IPv6.

--- Additional comment from mkollar@redhat.com on 2012-02-21 04:42:30 EST ---

Created attachment 564620 [details]
Output of "osad -N -vvvv" while registered to proxy.

Attaching output of "osad -N -vvvv" while registered to proxy.

--- Additional comment from mkollar@redhat.com on 2012-02-21 04:43:52 EST ---

Created attachment 564621 [details]
Output of "osad -N -vvvv" while registered to directly to spacewalk.

Attaching output of "osad -N -vvvv" while registered to directly to spacewalk.

--- Additional comment from msuchy@redhat.com on 2012-03-01 10:17:39 EST ---

This is caused by s2s not communicating between two instances of jabberd server.

I find this relevant report in upstream:
https://bugs.launchpad.net/jabberd2/+bug/374687

Flipping to jabberd.

Can you please communicate with upstream to do some release and rebase to it?
Comment 1 Adrian Reber 2012-03-10 11:16:55 EST
Where do you need to fix? rawhide only?
Comment 2 Miroslav Suchý 2012-03-10 11:52:39 EST
This bug is for RHN Satellite on RHEL. You meant fix for Bug #795680? Then yes, rawhide would be good start.
Comment 3 Adrian Reber 2012-03-10 12:07:31 EST
Ah, okay. I way confused why there were two open bugs.
Comment 8 Milan Zazrivec 2012-08-14 07:53:06 EDT
spacewalk.git master: 6c97648eb2900209a85ca997f87c35c0c8920d4b
Comment 10 Milan Zazrivec 2012-08-14 08:09:42 EDT
To make the thing work, we don't need the patch mentioned in
https://bugs.launchpad.net/jabberd2/+bug/374687 at all.

All we need is to enable /s2s/lookup/resolve-ipv6 in jabberd's setup.
Comment 14 Milan Zazrivec 2012-09-04 11:46:23 EDT
The following network setup:

    Satellite 5.5 -> | IPv6 connection | -> RHN Proxy 5.5 ->
                  -> | IPv4 connection | -> Client

works just fine for me.

I'm guessing problem from comment #12 is a network configuration problem.

I'm returning this back to ON_QA.

Note You need to log in before you can comment on or make changes to this bug.