Bug 800334 - chkconfig --list should be able to say whats the service startup status
chkconfig --list should be able to say whats the service startup status
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chkconfig (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: beta
: ---
Assigned To: Lukáš Nykrýn
Juraj Marko
: Regression, Reopened
: 879373 (view as bug list)
Depends On:
Blocks: 802465 959971 1044717 816135
  Show dependency treegraph
 
Reported: 2012-03-06 05:43 EST by Petr Sklenar
Modified: 2015-08-31 23:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:19:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
systemctl list-dependencies (3.24 KB, text/plain)
2013-01-18 07:23 EST, Lukáš Nykrýn
no flags Details

  None (edit)
Description Petr Sklenar 2012-03-06 05:43:32 EST
Description of problem:
I dont know if its related to systemd or chkonfig manipulation but its hard to find which services should be started during startup and which not.

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.0 Alpha1 (Maipo)

How reproducible:
deterministic

Steps to Reproduce:

# rpm -q vsftpd
vsftpd-2.3.4-5.el7.x86_64
# chkconfig vsftpd on
error reading information on service vsftpd: No such file or directory

  
Actual results:
chkconfig --list is supported when I read man pages in rhel7
chkconfig vsftpd on/off doesnt work
chkconfig sshd on/off does work but I am not able to find out its status by chkconfig

Expected results:
chkconfig sshd --list shows current status

Additional info:
Comment 5 Lukáš Nykrýn 2012-10-30 08:13:37 EDT
Question is what do want from its output, if it is sufficient that service is enabled/disabled and is wanted by that target, this should be quite easy to implement, but whole picture of all dependency can be probably viewed only by systemctl dot.
Comment 6 Lukáš Nykrýn 2012-11-01 04:00:31 EDT
If we introduce this RFE in systemd https://bugzilla.redhat.com/show_bug.cgi?id=795365 would it be sufficient solution?
Comment 9 Lukáš Nykrýn 2013-01-18 07:23:00 EST
Created attachment 682394 [details]
systemctl list-dependencies

We have added command to systemctl (for now it is only in upstream repository), which can be used to determine what services are enabled on specified target. Is this sufficient solution for you?
Comment 10 Petr Sklenar 2013-02-06 04:32:27 EST
Hello,
I guess that there are all startup services in that list, right?

chkconfig --list should say:
1, name of the service (which is in you list)
2, status if service should be started after bootup 
3, Are there services which are not running?
4, Are there service which I can start?
Generaly I would like to see the list of all available services in the system?

For ex: 
rhel6: chkconfig --list shows:
ypxfrd         	0:off	1:off	2:off	3:off	4:off	5:off	6:off
Comment 11 Lukáš Nykrýn 2013-02-22 12:49:06 EST
*** Bug 879373 has been marked as a duplicate of this bug. ***
Comment 12 Lukáš Nykrýn 2013-02-22 12:51:14 EST
I have added suggestion to call systemctl in --list error message. Please note that list-dependencies command will be in systemd-198.
http://git.fedorahosted.org/cgit/chkconfig.git/commit/?id=c3a81fea271fc7fb5bf224b2036cdb6991220060
Comment 13 Lukáš Nykrýn 2013-03-26 10:05:21 EDT
list-dependencies is now in systemd-198 a chkconfig --list suggests to use it, so I will close this as WONTFIX.
Comment 18 Ludek Smid 2014-06-13 06:19:26 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.