Bug 800345 - Issues with unicode support in simplejson-2.0.9 - fixed in 2.1.0 and above, consider upgrade or backport
Issues with unicode support in simplejson-2.0.9 - fixed in 2.1.0 and above, c...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: python-simplejson (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Python Maintainers
Red Hat Satellite QA List
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 06:22 EST by Lev Shamardin
Modified: 2016-07-14 11:13 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-14 11:13:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for the package (6.25 KB, patch)
2012-03-14 07:23 EDT, Lev Shamardin
no flags Details | Diff

  None (edit)
Description Lev Shamardin 2012-03-06 06:22:50 EST
Description of problem:

We have encountered this issue on our production systems: http://code.google.com/p/simplejson/issues/detail?id=48

It is fixed in simplejson 2.1.0 and above. Is it possible to update EPEL5 to a newer version? If not, I could backport the bugfix to simplejson 2.0.9

Version-Release number of selected component (if applicable):

python-simplejson-2.0.9-8.el5
Comment 1 Toshio Ernie Kuratomi 2012-03-08 20:12:16 EST
A backport would be preferred as end user visible changes happened in 2.1.0.

Let us know if you've given up on a backport, though, and we'll re-evaluate the impact of an updated version.
Comment 2 Lev Shamardin 2012-03-14 07:23:41 EDT
Created attachment 569965 [details]
Proposed patch for the package
Comment 3 Lev Shamardin 2012-03-14 07:26:14 EDT
Since EPEL contained an older release (python-simplejson-2.0.9-3.el5) then the RHEL one, I had to do some extra merging. I attached a proposed patch for the package to this report. What has changed:

1. I merged EPEL version 2.0.9-3 with RHEL version 2.0.9-8.
2. I added the required patch for the unicode issue.

Complete patched SRPM is available here: http://fedorapeople.org/~abbot/python-simplejson-2.0.9-10.el5.centos.src.rpm

This patch solves the issue for me, I would be glad to see it in EPEL pretty soon :)
Comment 4 Toshio Ernie Kuratomi 2012-03-15 11:11:13 EDT
I was unaware that RHEL5 is now shipping python-simplejson :-(  EPEL can't ship packages that RHEL is shipping.  This will need to be targeted against the RHEL package and I'll have to retire the EPEL5 python-simplejson.

I'm very sorry I didn't see that piece earlier.

Reassigning to RHEL maintainer.
Comment 5 Brandon Burton 2012-04-12 14:57:37 EDT
We've had a request from our developers for 2.1.x, as it greatly improves the error reporting in the library.

So Mozilla is giving a big +1 to having a backport or updated version, as it looks like it hasn't gotten much recent love, https://rhn.redhat.com/network/software/packages/change_log.pxt?pid=584618

Let me know if I should be looking somewhere besides https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=584618 for updates

To note, we'd like to see it for RHEL6
Comment 6 Dave Malcolm 2013-03-21 02:43:45 EDT
As Red Hat Enterprise Linux 5 has now entered Production Phase 2, this bug has been re-evaluated with the conclusion that a fix would not be appropriate at this time. Consequently this bug is being moved to Red Hat Enterprise Linux 6. Please contact your Red Hat representative if a review is required.
Comment 9 RHEL Product and Program Management 2013-10-13 20:46:55 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 10 Petr Viktorin 2016-07-14 11:13:19 EDT
Red Hat Enterprise Linux version 6 is entering the Production 2 phase of its lifetime and this bug doesn't meet the criteria for it, i.e. only high severity issues will be fixed. Please see https://access.redhat.com/support/policy/updates/errata/ for further information.

I suggest using "json" (from the standard library in Python 2.6+) instead of simplejson.

Note You need to log in before you can comment on or make changes to this bug.