Bug 800349 - [ovirt] [vdsm] flow-ID is not passed in migration flow
[ovirt] [vdsm] flow-ID is not passed in migration flow
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-engine-core (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3
Assigned To: Barak
virt
:
Depends On:
Blocks: 902971 894399 919413
  Show dependency treegraph
 
Reported: 2012-03-06 06:30 EST by Haim
Modified: 2014-01-12 19:51 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 03:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 12971 None None None Never
oVirt gerrit 13011 None None None Never

  None (edit)
Description Haim 2012-03-06 06:30:28 EST
Description of problem:

scenario: 

- migrate vm using web-admin
- backend send command to migrate vm to src host with flow-id:

2012-03-06 13:28:56,711 INFO  [org.ovirt.engine.core.bll.MigrateVmCommand] (pool-5-thread-7) [1f93ac9a] Running command: MigrateVmCommand internal: false. Entities affected :  ID: 6e7da0b2-a19f-4020-a9b6-4fd1982b61f6 Type: VM
2012-03-06 13:28:56,717 INFO  [org.ovirt.engine.core.vdsbroker.MigrateVDSCommand] (pool-5-thread-7) [1f93ac9a] START, MigrateVDSCommand(vdsId = d05ed726-5bd5-11e1-b3d5-0fa1db0ec1ef, vmId=6e7da0b2-a19f-4020-a9b6-4fd1982b61f6, srcHost=nott-vds2.qa.lab.tlv.redhat.com, dstVdsId=a2859be4-5d35-11e1-886f-af102fbd5669, dstHost=nott-vds1.qa.lab.tlv.redhat.com:54321, migrationMethod=ONLINE), log id: 60cf6fb0
2012-03-06 13:28:56,719 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MigrateBrokerVDSCommand] (pool-5-thread-7) [1f93ac9a] VdsBroker::migrate::Entered (vm_guid=6e7da0b2-a19f-4020-a9b6-4fd1982b61f6, srcHost=nott-vds2.qa.lab.tlv.redhat.com, dstHost=nott-vds1.qa.lab.tlv.redhat.com:54321,  method=online
2012-03-06 13:28:56,719 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MigrateBrokerVDSCommand] (pool-5-thread-7) [1f93ac9a] START, MigrateBrokerVDSCommand(vdsId = d05ed726-5bd5-11e1-b3d5-0fa1db0ec1ef, vmId=6e7da0b2-a19f-4020-a9b6-4fd1982b61f6, srcHost=nott-vds2.qa.lab.tlv.redhat.com, dstVdsId=a2859be4-5d35-11e1-886f-af102fbd5669, dstHost=nott-vds1.qa.lab.tlv.redhat.com:54321, migrationMethod=ONLINE), log id: 1f1b8003
2012-03-06 13:28:56,726 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.MigrateBrokerVDSCommand] (pool-5-thread-7) [1f93ac9a] FINISH, MigrateBrokerVDSCommand, log id: 1f1b8003
2012-03-06 13:28:56,737 INFO  [org.ovirt.engine.core.vdsbroker.MigrateVDSCommand] (pool-5-thread-7) [1f93ac9a] FINISH, MigrateVDSCommand, return: MigratingFrom, log id: 60cf6fb0

- command is then passed to vdsm (src): 

Thread-1682::DEBUG::2012-03-06 13:28:14,121::BindingXMLRPC::848::vds::(wrapper) client [10.35.97.30]::call vmMigrate with ({'src': 'nott-vds2.qa.lab.tlv.redhat.com', 'dst': 'nott-vds1.qa.lab.tlv.redhat.com:54321', 'vmId': '6e7da0b2-a19f-4020-a9b6-4fd1982b61f6', 'method': 'online'},) {} flowID [1f93ac9a]

- command is not passed to vdsm on destination server
Comment 1 Michal Skrivanek 2013-03-12 09:18:19 EDT
*** Bug 919413 has been marked as a duplicate of this bug. ***
Comment 2 Itamar Heim 2013-03-13 21:12:28 EDT
michael - is http://gerrit.ovirt.org/13011 solving this as well?
Comment 3 mkublin 2013-03-14 04:02:26 EDT
Yes, it should
Comment 5 Itamar Heim 2013-08-21 12:41:07 EDT
as RC is built, moving to ON_QA (hopefully did not catch incorrect bugs when doing this)
Comment 6 Itamar Heim 2013-09-23 03:33:47 EDT
closing as this should be in 3.3 (doing so in bulk, so may be incorrect)

Note You need to log in before you can comment on or make changes to this bug.