Bug 800477 - could not open /usr/share/litmus/htdocs/foo: No such file or directory
could not open /usr/share/litmus/htdocs/foo: No such file or directory
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: litmus (Show other bugs)
el5
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ricardo Rocha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 09:31 EST by Greg Swift
Modified: 2013-08-31 13:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-26 03:44:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Swift 2012-03-06 09:31:28 EST
Description of problem:
Attempted to run the program but it errors because it can not find its sample files (stored in a htdocs subdir).

Version-Release number of selected component (if applicable):
0.13-3.el5

How reproducible:
very

Steps to Reproduce:
1. Install litmus RPM
2. run 'litmus <url>'

  
Actual results:
The error "FAIL (could not open /usr/share/litmus/htdocs/foo: No such file or directory)"

Expected results:
the program to run

Additional info:
Just to verify that the RPM wasn't putting the files in a different location so i did an 'rpm -ql litmus' and there is no a foo:

[root@penguin ~]# rpm -ql litmus
/usr/bin/litmus
/usr/libexec/litmus
/usr/libexec/litmus/basic
/usr/libexec/litmus/copymove
/usr/libexec/litmus/http
/usr/libexec/litmus/locks
/usr/libexec/litmus/props
/usr/share/doc/litmus-0.13
/usr/share/doc/litmus-0.13/COPYING
/usr/share/doc/litmus-0.13/FAQ
/usr/share/doc/litmus-0.13/README
/usr/share/doc/litmus-0.13/THANKS
/usr/share/doc/litmus-0.13/TODO


I did go check upstream, and the file is there.
Comment 1 Fedora Update System 2012-03-16 12:12:57 EDT
litmus-0.13-5.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/litmus-0.13-5.el5
Comment 2 Fedora Update System 2012-03-16 12:13:03 EDT
litmus-0.13-5.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/litmus-0.13-5.fc16
Comment 3 Fedora Update System 2012-03-16 12:13:08 EDT
litmus-0.13-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/litmus-0.13-5.fc17
Comment 4 Fedora Update System 2012-03-16 12:13:15 EDT
litmus-0.13-5.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/litmus-0.13-5.el6
Comment 5 Ricardo Rocha 2012-03-16 12:17:09 EDT
Please test and give karma as appropriate.

Cheers,
  Ricardo
Comment 6 Greg Swift 2012-03-16 12:23:40 EDT
tested in rhel5.  works for me. karma given
Comment 7 Fedora Update System 2012-05-04 22:09:13 EDT
Package litmus-0.13-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing litmus-0.13-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-7350/litmus-0.13-5.fc17
then log in and leave karma (feedback).
Comment 8 Greg Swift 2012-05-04 23:37:03 EDT
i dont have f17 so i wont be able to test that for you, but the epel5 one worked great and I did karma it.
Comment 9 Fedora Update System 2012-05-26 03:44:18 EDT
litmus-0.13-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Fedora Update System 2012-06-05 13:05:27 EDT
litmus-0.13-5.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2012-06-15 19:50:26 EDT
litmus-0.13-5.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Mathieu Baudier 2012-11-11 04:59:54 EST
The problem still occurs on CentOS 6 / EPEL 6

litmus.x86_64                          0.13-3.el6                          @epel
Comment 13 Michael Monreal 2013-08-31 13:29:35 EDT
Still broken in 0.13-3.el6 as of today.

Note You need to log in before you can comment on or make changes to this bug.