Bug 800490 - chkconfig <xinetd_service> on does NOT start service
chkconfig <xinetd_service> on does NOT start service
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: chkconfig (Show other bugs)
7.0
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Bill Nottingham
qe-baseos-daemons
: Regression
Depends On:
Blocks: 802465 816135
  Show dependency treegraph
 
Reported: 2012-03-06 10:01 EST by Petr Sklenar
Modified: 2014-03-16 23:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 17:16:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2012-03-06 10:01:20 EST
Description of problem:
when xinetd is running then chkconfig should start xinetd_services 

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux Server release 7.0 Alpha1 (Maipo)

How reproducible:
deterministic

Steps to Reproduce:


1. # service xinetd restart
Redirecting to /bin/systemctl  restart xinetd.service

# service xinetd status
Redirecting to /bin/systemctl  status xinetd.service
xinetd.service - Xinetd A Powerful Replacement For Inetd
	  Loaded: loaded (/lib/systemd/system/xinetd.service; enabled)
	  Active: active (running) since Tue, 06 Mar 2012 09:56:22 -0500; 2min 27s ago
	 Process: 13987 ExecStart=/usr/sbin/xinetd -stayalive -pidfile /var/run/xinetd.pid $EXTRAOPTIONS (code=exited, status=0/SUCCESS)
	Main PID: 13991 (xinetd)
	  CGroup: name=systemd:/system/xinetd.service
		  └ 13991 /usr/sbin/xinetd -stayalive -pidfile /var/run/xinetd.pid


2. # rdate -p localhost
rdate: couldn't connect to host localhost: Connection refused
3. # chkconfig time-dgram on
4. # chkconfig time-stream on
5. # rdate -p localhost
rdate: couldn't connect to host localhost: Connection refused
6. # service xinetd restart
Redirecting to /bin/systemctl  restart xinetd.service
7. # rdate -p localhost
rdate: [localhost]	Tue Mar  6 09:52:08 2012

 
Actual results:
xinetd restart is needed. Its different behavior compare to rhel[56]

Expected results:
no xinetd restart is needed
step 5 should work


Additional info:
this is rhel6 behavior:

[root@hp-xw4200-01 tmp.NtQszGdpJ5]# rdate -p localhost
rdate: couldn't connect to host localhost: Connection refused
[root@hp-xw4200-01 tmp.NtQszGdpJ5]# chkconfig  time-stream on
[root@hp-xw4200-01 tmp.NtQszGdpJ5]#  chkconfig time-dgram on
[root@hp-xw4200-01 tmp.NtQszGdpJ5]# rdate -p localhost
rdate: [localhost]	Tue Mar  6 09:58:10 2012
Comment 1 Bill Nottingham 2012-03-06 11:37:05 EST
Fixed upstream:

http://git.fedorahosted.org/git/?p=chkconfig.git;a=commitdiff;h=6b1b0fbd7cb3afdfc4d1cdfe3639a6b30b148404

Not intending to pull this back for Alpha 1 unless people really really want this.

Note You need to log in before you can comment on or make changes to this bug.