Bug 800517 - French: missing translation causes broken styles
French: missing translation causes broken styles
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Dave Johnson
wes hayutin
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 11:16 EST by Matt Wagner
Modified: 2014-08-17 18:27 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Translations were missing for Cloud Engine (French), which caused the format of some web pages to display improperly. This bug fix adds in the missing French translation. Cloud Engine (French) displays the correct web page format.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:58:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
good 2 go (105.20 KB, image/png)
2012-06-21 12:44 EDT, Dave Johnson
no flags Details

  None (edit)
Description Matt Wagner 2012-03-06 11:16:18 EST
Description of problem:
If you view the Providers Edit page (at least), the formatting is all messed up, like a tag wasn't closed.

Viewing the source, I see:

<input class="long" id="provider_deltacloud_provider" name="provider[deltacloud_provider]" size="30" title="<span class="translation_missing" title="translation missing: fr.providers.form.x_deltacloud_provider.generic">Generic</span>" type="text" value="" />

That missing translation is messing up the display. We should just add the required translations.


Version-Release number of selected component (if applicable):
1.0-product as of c9d5bf660e5d5511becc256c58b0b0df5dc06908


How reproducible:
100%

Steps to Reproduce:
1. Set your browser's preferred language to French
2. Attempt to edit a provider
3. Recoil in disgust at how the page looks messed up
4. Optionally, view source and find "translation missing" text
Comment 1 Matt Wagner 2012-03-07 10:43:18 EST
en.yml now has this in the providers.form section -- but it doesn't seem to be in other language files:

      x_deltacloud_provider:
        generic: X-Deltacloud-Provider
        ec2: EC2 Region
        rhevm: RHEV-M API_PROVIDER
        vsphere: vSphere API hostname
Comment 2 Matt Wagner 2012-03-07 10:52:18 EST
It sounds like this is a known issue -- we've got a bunch of strings we're going to get the translators add. So this is effectively ON_DEV for the translators. I'm going to leave this open for now so we can make sure this is resolved.
Comment 3 Angus Thomas 2012-06-20 13:04:23 EDT
Please re-test against 1.0.1
Comment 4 Dave Johnson 2012-06-21 12:44:09 EDT
Created attachment 593505 [details]
good 2 go

looks good in v1.0.1
Comment 7 errata-xmlrpc 2012-12-04 09:58:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.