Bug 800650 - Add symlinks for common fence types that utilize standards based agents
Add symlinks for common fence types that utilize standards based agents
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: fence-agents (Show other bugs)
6.3
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks: 917747 917838 969136 1031888
  Show dependency treegraph
 
Reported: 2012-03-06 16:12 EST by Perry Myers
Modified: 2013-11-18 23:59 EST (History)
6 users (show)

See Also:
Fixed In Version: fence-agents-3.1.5-20.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 917747 917838 (view as bug list)
Environment:
Last Closed: 2013-02-21 02:41:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (4.22 KB, patch)
2012-06-14 09:03 EDT, Marek Grac
no flags Details | Diff

  None (edit)
Description Perry Myers 2012-03-06 16:12:01 EST
Description of problem:
Fence devices like iLO3 and iDrac utilize fence_ipmilan, but there is confusion among users because they see things like:

fence_ilo and fence_drac5 and try to use those agents instead of using IPMI

So for certain cases like iLO3 and iDrac it may be worthwhile to create a symlink to fence_ipmilan so that it is more obvious that those devices map to the IPMI based fence agent.

So what I can see would be:

fence_ilo2->fence_ilo
fence_ilo3->fence_ipmilan
fence_idrac->fence_ipmilan
fence_imm->fence_ipmilan

In addition, we might be able to optimize user experience by detecting which file was called and then setting args based on that.  For example, if fence_ilo3 was called, then fence_ipmilan can automatically set power_wait to be 4 (if it was not explicitly set)
Comment 4 Marek Grac 2012-06-14 09:03:45 EDT
Created attachment 591829 [details]
Proposed patch

This patch adds support for creating symlink fence agents for fencing library (example with ilo2) and ipmilan (example with ilo3). We will have to decide which symlinks should be added.
Comment 10 Marek Grac 2012-10-25 05:03:01 EDT
Unit test for (fence_ilo2, fence_ilo3, fence_imm, fence_idrac)

fence_? -o metadata 

Functionality of agents needs to be checked only for fence_ilo3 (different default values)

fence_ilo3 -o status -l LOGIN -p PASS -a IP
Comment 13 errata-xmlrpc 2013-02-21 02:41:15 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0286.html

Note You need to log in before you can comment on or make changes to this bug.