Bug 800662 - Buttons off the screen
Buttons off the screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
:
: 753985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 16:44 EST by Stef Walter
Modified: 2013-07-04 09:01 EDT (History)
9 users (show)

See Also:
Fixed In Version: firstboot-17.2-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 18:55:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of problem (755.11 KB, image/jpeg)
2012-03-06 16:44 EST, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2012-03-06 16:44:25 EST
Created attachment 568074 [details]
Picture of problem

Description of problem:

When entering up the firstboot anaconda installer component, the buttons near the bottom of the window are positioned off the screen. This may be due to multiple monitors.

This is better than in FC16, where the anaconda installer tried to span multiple monitors. However it'll still be confusing to users, who won't know how to alt-drag the window upwards to get to the buttons.

Version-Release number of selected component (if applicable):

FC 17 Alpha

How reproducible:

First boot only runs once.

Actual results:

No buttons visible by default.

Expected results:

Buttons should be usable.
Additional info:
Comment 1 Martin Gracik 2012-03-14 05:34:48 EDT
What window manager did you install?

metacity, kwin, xfwm4, or openbox?
Comment 2 Stef Walter 2012-03-14 06:58:12 EDT
This is Fedora 17 Alpha, and I didn't customize the install at all. So the window manager installed would be mutter (ie: gnome-shell).
Comment 3 Ray Strode [halfline] 2012-03-15 12:19:01 EDT
Stef on irc said he has multiple monitors of slightly different dimensions.  This means the X screen size is probably larger than the monitor firstboot is displayed on.  The code has this:

   self._y_size = gtk.gdk.screen_height()

and later

self.leftEventBox.set_size_request(leftWidth, self._y_size)

So that would explain this.  It probably needs to query the dimensions of the appropriate monitor instead of the overarching screen.
Comment 4 Martin Gracik 2012-04-19 08:12:44 EDT
*** Bug 753985 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-04-20 03:31:19 EDT
firstboot-17.2-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/firstboot-17.2-1.fc17
Comment 6 Fedora Update System 2012-04-21 17:03:14 EDT
Package firstboot-17.2-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-17.2-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-6318/firstboot-17.2-1.fc17
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-05-04 18:55:44 EDT
firstboot-17.2-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.