Bug 800690 - NM 0.9.3.995-0.4.git20120302.fc17 fails to bring up network
NM 0.9.3.995-0.4.git20120302.fc17 fails to bring up network
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-06 18:30 EST by Orion Poplawski
Modified: 2012-03-17 20:46 EDT (History)
2 users (show)

See Also:
Fixed In Version: NetworkManager-0.9.3.995-0.6.git20120314.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-17 20:46:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NetworkManager --no-daemon --log-level=debug output (4.88 KB, text/plain)
2012-03-13 17:13 EDT, Orion Poplawski
no flags Details
output from "NetworkManager --no-daemon --log-level=debug >output 2>&1" (4.75 KB, text/plain)
2012-03-13 22:51 EDT, John Ellson
no flags Details

  None (edit)
Description Orion Poplawski 2012-03-06 18:30:01 EST
Description of problem:

Updating to 0.9.3.995-0.4.git20120302.fc17 causes the network to fail to come up.  Reverting to 0.2.git20120215 fixes.  systemctl start network.service also brings the network up.

Mar  6 04:36:45 vmf17 NetworkManager[6029]: <info> Networking is enabled by state file
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <warn> failed to allocate link cache
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <info> (eth0): carrier is OFF
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <error> [1331033805.940807] [nm-device-ethernet.c:456] real_update_permanent_hw_address(): (eth0): unable to read permanent MAC address (error 0)
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <info> (eth0): new Ethernet device (driver: 'virtio_net' ifindex: 2)
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <info> (eth0): exported as /org/freedesktop/NetworkManager/Devices/0
Mar  6 04:36:45 vmf17 dbus-daemon[437]: dbus[437]: [system] Activation via systemd failed for unit 'dbus-org.bluez.service': Unit dbus-org.bluez.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.bluez.service' for details.
Mar  6 04:36:45 vmf17 NetworkManager[6029]: <info> (eth0): now managed
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): device state change: unmanaged -> unavailable (reason 'managed') [10 20 2]
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): bringing up device.
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): carrier now ON (device state 20)
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): device state change: unavailable -> disconnected (reason 'carrier-changed') [20 30 40]
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): preparing device.
Mar  6 04:36:46 vmf17 NetworkManager[6029]: <info> (eth0): deactivating device (reason 'managed') [2]
Comment 1 John Ellson 2012-03-09 19:36:03 EST
I'm seeing the same problem (I think):
  - it only affects f17;  f16 and rawhide not showing the same  problem
  - affects both i686 and x86_64
  - ifconfig shows an IPV6 address, but no IPV4
  - "service network restart" works
Comment 2 John Ellson 2012-03-09 19:42:43 EST
I'm seeing the same problem:
  - it only affects f17
         -- f16 not showing the same problem
         -- rawhide not showing the same problem even
               though it has the same version of NM    <<<<<NB
  - affects both i686 and x86_64
  - ifconfig shows an IPV6 address, but no IPV4        <<<<<NB
  - "service network restart" works
  - confirmed that reverting to 0.9.3-0.2.git20120215 works on both i686 and x86_64
Comment 3 Dan Williams 2012-03-13 16:49:15 EDT
Mind giving:

https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.5.git20120313.fc17

a shot?  If that doesn't work, can you, as root:

1) systemctl stop NetworkManager
2) NetworkManager --no-daemon --log-level=debug

and see what happens for me?
Comment 4 Orion Poplawski 2012-03-13 17:13:36 EDT
Created attachment 569790 [details]
NetworkManager --no-daemon --log-level=debug output

New update doesn't work
Comment 5 John Ellson 2012-03-13 17:32:54 EDT
It may have partially worked for me.

ifconfig now shows an IP4 address, but the machine is still inaccessible because a number of other deamons are now not getting started.  I noticed: sshd, avaihi-daemon, and gpm were not started.  There might be others.

I have to out ... I'll generate a trace from --no-daemon in a couple of hours and attach here....
Comment 6 Orion Poplawski 2012-03-13 17:37:51 EDT
For me, when I installed the update and restarted NM, the network stayed up.  But when I rebooted, NM could not bring the network up.
Comment 7 John Ellson 2012-03-13 22:45:46 EDT
Sorry.  Ignore comment #5.  I was looking at the wrong virtual machine.

Basically no change from the fix.  Still no IP4 address assigned.
Comment 8 John Ellson 2012-03-13 22:51:52 EDT
Created attachment 569853 [details]
output from "NetworkManager --no-daemon --log-level=debug >output 2>&1"

This was the output from NM startup.   I did not include the ^C termination part.
Comment 9 Fedora Update System 2012-03-14 14:22:27 EDT
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/NetworkManager-0.9.3.995-0.6.git20120314.fc17
Comment 10 John Ellson 2012-03-15 12:45:49 EDT
NetworkManager-0.9.3.995-0.6.git20120314.[fc17|fc18].[i686|x86_64] 
all work for me.
Comment 11 Dan Williams 2012-03-15 18:38:44 EDT
(In reply to comment #10)
> NetworkManager-0.9.3.995-0.6.git20120314.[fc17|fc18].[i686|x86_64] 
> all work for me.

Great, thanks for testing; if you can Karma+1 it like Orion did, that'd also be great :)
Comment 12 Fedora Update System 2012-03-15 22:43:36 EDT
Package NetworkManager-0.9.3.995-0.6.git20120314.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.9.3.995-0.6.git20120314.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-3861/NetworkManager-0.9.3.995-0.6.git20120314.fc17
then log in and leave karma (feedback).
Comment 13 Fedora Update System 2012-03-17 20:46:17 EDT
NetworkManager-0.9.3.995-0.6.git20120314.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.