Bug 800732 - python-rhsm depends on python-simplejson that is not needed basically
python-rhsm depends on python-simplejson that is not needed basically
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-rhsm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.0
Assigned To: Bryan Kearney
IDM QE LIST
:
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-03-07 00:45 EST by Satoru SATOH
Modified: 2014-06-17 20:22 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.10.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:42:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
An experimental patch to remove extra dependency to python-simplejson (2.04 KB, patch)
2012-03-07 00:45 EST, Satoru SATOH
no flags Details | Diff

  None (edit)
Description Satoru SATOH 2012-03-07 00:45:48 EST
Created attachment 568140 [details]
An experimental patch to remove extra dependency to python-simplejson

Description of problem:
python-rhsm depends on python-simplejson but python in RHEL 6 provides
it (as 'json' module) so this dependency is not needed basically, I think.

FYI. json (simplejson) was added in python itself since 2.6 and the version
of pyhon in RHEL 6 is 2.6.x:
http://docs.python.org/whatsnew/2.6.html


Version-Release number of selected component (if applicable):
confirmed with python-rhsm-0.96.15-1 in RHEL 6.2.

  
Additional info:
I'll upload an experimental patch to fix it. I didn't test the patch
but it should work on both RHEL 5 and 6, I guess.
Comment 4 RHEL Product and Program Management 2012-07-10 04:41:18 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 RHEL Product and Program Management 2012-07-10 21:59:06 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-12-14 03:48:05 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 Bryan Kearney 2013-10-11 11:12:10 EDT
https://github.com/candlepin/python-rhsm/pull/94
Comment 11 Sharath Dwaral 2013-11-05 18:23:01 EST
Verified in 

https://bugzilla.redhat.com/show_bug.cgi?id=1006748#c3


Marking VERIFIED
Comment 12 Ludek Smid 2014-06-13 08:42:03 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.