Bug 800735 - NLM on IPv6 does not work as expected
NLM on IPv6 does not work as expected
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: nfs (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vinayaga Raman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 00:51 EST by Sachidananda Urs
Modified: 2014-03-30 21:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-04 06:30:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: DP
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Program to test locks (38.27 KB, text/x-csrc)
2012-03-07 00:52 EST, Sachidananda Urs
no flags Details

  None (edit)
Description Sachidananda Urs 2012-03-07 00:51:40 EST
Description of problem:

- Open a file and lock a certain region and write data.
- Allow another process to lock the file, it should block - blocks.
- Check data to ensure that it has blocked.
- Now unlock the region and the other process should lock and write data

Unlocks but the other process does not lock the file and write data. Process goes into D state.

The same exercise works on FUSE, local FS, and Kernel NFS.

Find the attached program.

Version-Release number of selected component (if applicable):

glusterfs-3.3.0qa25

How reproducible:

Always. Program attached.
Comment 1 Sachidananda Urs 2012-03-07 00:52:19 EST
Created attachment 568142 [details]
Program to test locks
Comment 2 Krishna Srinivas 2012-03-08 08:46:58 EST
This is because pmap_getport does not support AF_INET6. doing "ifconfig eth0 del <ipv6 addr>" fixes the behavior seen above.

Need to investigate on IPv6 support for NLM, for now making it work on Ipv4 only for QA.
Comment 3 Anand Avati 2012-03-10 04:09:34 EST
CHANGE: http://review.gluster.com/2909 (nlm: support ipv4 only) merged in master by Vijay Bellur (vijay@gluster.com)
Comment 4 Sachidananda Urs 2012-03-26 05:22:53 EDT
Works on latest code, but not sure whether to close this. Since the fix is not complete but just a work around for now.
Comment 5 Sachidananda Urs 2012-04-25 08:32:35 EDT
Kris/Divya can you confirm if this is documented. If so, I can mark this as verified.
Comment 6 Divya 2012-04-25 08:55:24 EDT
I have added it as Known Issue in Release Notes and it is available on the staging server at: http://documentation-stage.bne.redhat.com/docs/en-US/Red_Hat_Storage/2/html/2.0_Release_Notes/chap-Release_Notes-Known_Issues.html

Note You need to log in before you can comment on or make changes to this bug.