Bug 800736 - Freemind (java) loses keyboard input when used with ibus
Freemind (java) loses keyboard input when used with ibus
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 00:58 EST by nomnex
Modified: 2012-03-26 05:36 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1145725 (view as bug list)
Environment:
Last Closed: 2012-03-26 05:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Jedit with ibus (37.11 KB, image/png)
2012-03-13 10:47 EDT, nomnex
no flags Details

  None (edit)
Description nomnex 2012-03-07 00:58:24 EST
Description of problem:

Please help with directions (package, or upstream bug tracker):
I have first reported a bug about the Freemind package, in 2011, after losing keyboard input when using Japanese
see: http://sourceforge.net/tracker/?func=detail&aid=3178894&group_id=7118&atid=107118

I have a limited understanding of interaction between the different software, but reading a similar issue ibus+java applications, see: https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/481656 and http://code.google.com/p/ibus/issues/detail?can=2&q=&colspec=ID%20Component%20Type%20Status%20Priority%20Stars%20Milestone%20Owner%20Summary&groupby=&sort=&id=419 (closed)

It seems that ibus, when used with Java applications, causes the lose of keyboard input.


Version-Release number of selected component (if applicable):
ibus 1.4.1
OpenJDK
freemind 0.9 (Java application)
Fedora 15


How reproducible: always


Steps to Reproduce:
1. Open freemind (ibus working)
2. either input English (my default language) either Japanese
3.
  
Actual results:

after some time, any key press is ineffective in the Java application. The workaround is to turn off ibus.


Expected results:

Input Japanese (using ibus) in Freemind.

Additional info:
Comment 1 fujiwara 2012-03-07 01:33:33 EST
Which shortcut keys do you try to use?
Comment 2 nomnex 2012-03-07 04:48:37 EST
no shortcut.

Ibus is running, I start Freemind. I can input English, or Japanese, but after a (short) time, any key press stop working in the Java application (I can only mouse click on the menus.)

It only affects the Freemind GUI, outside of it, I can type.

To re-gain keyboard input in Freemind, I must stop ibus. Then I can type again in Freemind. If I restart ibus, I can't input Japanese in the Freemind window (I can's select Japanese input[MOZEC or ANTHY] as long as Freemind window is in focus. If I click on a another window, I can select Japanese input as usual).

If I want to input Japanese again in Freemind, I must first terminate Freemind, and re-open it.
Comment 3 nomnex 2012-03-12 01:48:05 EDT
It there a way I can help debugging this on my end? I have no message when I launch Freemind from the terminal, and when the bug occurs.

After a few minutes of usage, I can not type anything in Freemind. The keyboard is not responsive. The only workaround is to quit ibus.

can you reproduce the issue, or am I the only one affected by this problem?

java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.6) (fedora-63.1.10.6.fc15-i386)
OpenJDK Client VM (build 20.0-b11, mixed mode)

Thank you.
Comment 4 fujiwara 2012-03-12 02:19:14 EDT
I don't think ibus does not work with Java applications.
I guess a Freemind bug or setting failures something. I'm a bit busy for F17.
It would be nice if you could confirmed the behavior with jedit.
Comment 5 nomnex 2012-03-13 10:47:03 EDT
Created attachment 569696 [details]
Jedit with ibus

(In reply to comment #4)
> I guess a Freemind bug or setting failures something. I'm a bit busy for F17.

Of course, I understand.

> It would be nice if you could confirmed the behavior with jedit.

I installed jedit jar (all platform) in my user directory for a test run. It may not be the proper installation, because Java path was not defined. I did not find a rpm jedit.

Running $ jedit, I can input Japanese fine.

This is the exact symptom I experience when I use Freemind & ibus:
--start--
https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/481656

I use ThinkingRock, a Java application, and after some time the keyboard input stops working for this application, meaning I can still use my mouse to manipulate the program, but I cannot type anything. When closing the iBus Daemon the input works again after some seconds. Also restarting the Java application helps to postpone the problem until it occurs again some minutes later.

I'm using Ubuntu 9.10 with version 1.2.0.20090927-2ubuntu2 of iBus and version 2.2.1 of ThinkingRock. My Java version is 6-15-1.

Please notice: I do NOT want to input Chinese or Japanese or anything like it. I just want to normally use my keyboard. I also have NO input method selected, I have the input methods turned OFF.

I have yet to test this behavior with other Java applications (maybe it's a bug in ThinkingRock?), so I'd be happy if somebody can confirm this bug for other Java applications. Because the solution is to quit the iBus Daemon, I suspect iBus to be the problem.
--end--

a ibus developer commented on the launchpad bug: Peng Huang (shawn-p-huang) #comment 3
Comment 6 nomnex 2012-03-13 19:46:53 EDT
I think I found the problem:

- This notebook suffers a LXDE panel bug (known bug).

- My other notebook with integrated GPU Intel and similar F-15 LXDE is not affected by the LXDE panel bug. I tried Freemind + ibus and it worked fine.

From this starting point, I changed ibus preferences: Show icon on system tree (Cleared)

It seems to work! I don't lose input in Freemind after a few minutes.


On question: I lost the ability to turn ibus input on-off with a mouse click (the input, not the daemon). What is the command line to turn ibus input on-off?

Thank you again.
Comment 7 nomnex 2012-03-14 02:27:34 EDT
It does not work...

after a few hours (vs. a few minutes, before) the bug is here again. The keyboard cannot input anything in the Freemind window, unless I kill ibus-daemon. Gosh.
Comment 8 nomnex 2012-03-26 05:36:50 EDT
The cause of the input problem was: LXPANEL.
Changing panel (XFCE) on my system solved the issue. I can input Japanese in Freemind.
See for information: https://bugzilla.redhat.com/show_bug.cgi?id=803098
Thank you.

Note You need to log in before you can comment on or make changes to this bug.