Bug 800807 - Missing pre-install step in ch. 6, determining the hardware clock time
Missing pre-install step in ch. 6, determining the hardware clock time
Status: CLOSED CURRENTRELEASE
Product: Fedora Documentation
Classification: Fedora
Component: install-guide (Show other bugs)
devel
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Bokoc
Ruediger Landmann
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 05:16 EST by Wayne Pollock
Modified: 2013-07-29 13:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-29 13:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Pollock 2012-03-07 05:16:47 EST
Description of problem:

Chapter 6 omits an important pre-install step, namely determining if the
hardware clock uses local time or UTC.  If Windows ME and older, it is local
time.  I believe Window7 and Vista use UTC.  On Linux, you can look
at the last line of /etc/adjtime, which is where this choice is recorded.  (It is either the streing "UTC" or "LOCAL".)

(Also, the "!" box in chapter 9.6 musty be updated; it says Windows uses local
time, but that depends on the version of Windows used.)

This step is especially important on dual-boot systems, the more so since Anaconda doesn't display the time from the hardware clock during the install.
Comment 1 Jack Reed 2012-04-26 00:56:56 EDT
Thanks, Wayne.

I've added a point to the System Specifications List explaining that users installing Fedora as an additional operating system should check how their hardware clock is set. I've mentioned /etc/adjtime.

However, my research indicates that Windows continues to natively use local time. Windows 7, however, can be configured to run the clock according to UTC.

Among other sources, see: http://answers.microsoft.com/en-us/windows/forum/windows_7-performance/does-windows-7-use-utc/e722ad92-a65b-4c0a-8c05-b8a84fb155d1

I've amended the warning in section 9.6 to note this.

These changes can be found in commit 135af08a5e4c89529dd81450069dce82f5a225bf and the draft version of the F17 Installation Guide, which should be available later today.

Note You need to log in before you can comment on or make changes to this bug.