Bug 800831 - inode numbers are different for the same file over nfs and fuse
inode numbers are different for the same file over nfs and fuse
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
pre-release
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Amar Tumballi
:
Depends On:
Blocks: 817967
  Show dependency treegraph
 
Reported: 2012-03-07 06:10 EST by Saurabh
Modified: 2016-01-19 01:09 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-24 13:53:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions: 3.3.0qa29
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2012-03-07 06:10:48 EST
Description of problem:
the inode numbers are different for same file over nfs and fuse mounts

Version-Release number of selected component (if applicable):
3.3.0qa25


How reproducible:
always

Steps to Reproduce:
1.create nfs and fuse mount
2.create a file
3.
  
Actual results:
the inode number is different

Expected results:
this bug filed to find the cause of the difference is their , as at present we think that the inode number should be same. 

Additional info:
Comment 1 krishnan parthasarathi 2012-03-07 23:07:34 EST
@saurabh, Why do you think it is a glusterd issue?
Comment 2 Amar Tumballi 2012-03-12 08:26:51 EDT
[root@supernova ~]# stat /mnt/glusterfs/abcd /mnt/nfs/abcd
  File: `/mnt/glusterfs/abcd'
  Size: 6         	Blocks: 16         IO Block: 131072 regular file
Device: 22h/34d	Inode: 10022916903501265893  Links: 8
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Context: system_u:object_r:fusefs_t:s0
Access: 2012-03-12 17:52:09.000000000 +0530
Modify: 2012-03-09 12:40:31.000000000 +0530
Change: 2012-03-12 17:37:50.000000000 +0530
 Birth: -
  File: `/mnt/nfs/abcd'
  Size: 6         	Blocks: 16         IO Block: 65536  regular file
Device: 27h/39d	Inode: 16535937926376003723  Links: 8
Access: (0644/-rw-r--r--)  Uid: (    0/    root)   Gid: (    0/    root)
Context: system_u:object_r:nfs_t:s0
Access: 2012-03-12 17:52:09.000000000 +0530
Modify: 2012-03-09 12:40:31.000000000 +0530
Change: 2012-03-12 17:37:50.000000000 +0530
 Birth: -
[root@supernova ~]# printf "0x%x 0x%x\n" 10022916903501265893 16535937926376003723
0x8b188dd1ee737be5 0xe57b73eed18d188b


[root@supernova ~]# getfattr -d -m . -e hex /tmp/export/a3/abcd
trusted.gfid=0xa04489d70f1946618b188dd1ee737be5


Some where in the code, we have a reverse logic of setting the inode numbers :-)
Comment 3 krishnan parthasarathi 2012-03-12 13:36:05 EDT
Amar, that still doesn't explain why it is a glusterd issue?
Comment 4 Amar Tumballi 2012-03-12 22:46:38 EDT
It is not. Hence I had moved the component to 'core' earlier itself.
Comment 5 Anand Avati 2012-03-14 06:06:00 EDT
CHANGE: http://review.gluster.com/2923 (nfs: no need to recalculate the 'ino' from gfid) merged in master by Vijay Bellur (vijay@gluster.com)

Note You need to log in before you can comment on or make changes to this bug.