Bug 800837 - Alert icons not displayed in the filter view alert column.
Alert icons not displayed in the filter view alert column.
Status: CLOSED CURRENTRELEASE
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
medium Severity low
: beta1
: ---
Assigned To: Matt Wagner
wes hayutin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 06:24 EST by Aziza Karol
Modified: 2014-08-17 18:27 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-13 14:49:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no alert icon (240.57 KB, image/png)
2012-03-07 06:25 EST, Aziza Karol
no flags Details
alert _icon (89.06 KB, image/png)
2012-09-20 08:00 EDT, pushpesh sharma
no flags Details

  None (edit)
Description Aziza Karol 2012-03-07 06:24:23 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
In the filter view of zones,applications and instances  we have added an extra column to display alert icons.

i have 3 alerts generated,but the alert icons is not getting displayed in the column. see attached screesnhot.

Expected results:
alert icons should get displayed.

Additional info:
rpm -qa | grep aeolus
aeolus-configure-2.5.0-17.el6.noarch
aeolus-conductor-0.8.0-40.el6.noarch
aeolus-conductor-doc-0.8.0-40.el6.noarch
aeolus-all-0.8.0-40.el6.noarch
rubygem-aeolus-cli-0.3.0-12.el6.noarch
aeolus-conductor-daemons-0.8.0-40.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-configserver-0.4.6-0.el6.noarch
Comment 1 Aziza Karol 2012-03-07 06:25:30 EST
Created attachment 568261 [details]
no alert icon
Comment 2 Dave Johnson 2012-03-07 14:20:02 EST
I am guessing this is related to 'vanished' state as well and is ultimately a duplicate of this state not being viewed as an 'error_state'.  Assigning to matt for comment.
Comment 3 Matt Wagner 2012-03-07 14:38:19 EST
I'm going to dig into the 'vanished' bug (#800849) first, which I hope will give me better insight into what's going on here, too.
Comment 4 Matt Wagner 2012-03-07 17:30:57 EST
It looks like Dave was exactly right here. I'm going to send a patch for #800849 which should fix this as well.
Comment 5 Matt Wagner 2012-03-07 17:55:26 EST
On second thought, the fix in #800849 will only incidentally help here. I sent a more explicit fix: http://lists.fedorahosted.org/pipermail/aeolus-devel/2012-March/009459.html
Comment 7 Matt Wagner 2012-03-20 09:52:49 EDT
Pushed to master:

commit d40b1b988062526635c498acb1d3669d25d439f4
Author: Matt Wagner <matt.wagner@redhat.com>
Date:   Wed Mar 7 17:50:47 2012 -0500

    BZ 800837 - Vanished instances are now included in failed?
    
    The failed? method on an instance was not considering STATE_VANISHED
    to be a failure, causing (among other things) the 'error' icon to not
    display in table view. This fixes this, and has the incidental benefit
    of making the code slightly more compact by using the existing FAILED_STATES
    constant instead of a series of checks.
    
    Resolves https://bugzilla.redhat.com/show_bug.cgi?id=800837
Comment 9 Mike Orazi 2012-04-18 11:39:58 EDT
It is not currently in the puddle as it was submitted to upstream after the code freeze.  

It looks like we should add 1.0.z and remove 1.0.0 flag.
Comment 12 Matt Wagner 2012-08-28 13:18:08 EDT
This is in the build now (just verified). Moving back to ON_QA.
Comment 14 pushpesh sharma 2012-09-20 08:00:16 EDT
Verified on:-
[root@dhcp201-113 ~]# rpm -qa|grep aeolus
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.13.8-1.el6cf.noarch
aeolus-conductor-0.13.8-1.el6cf.noarch
rubygem-aeolus-cli-0.7.1-1.el6cf.noarch
aeolus-configure-2.8.6-1.el6cf.noarch
aeolus-conductor-daemons-0.13.8-1.el6cf.noarch
aeolus-conductor-doc-0.13.8-1.el6cf.noarch

Steps:-

launch a application when deltacloud-core service is stopped.Results in "create_failed" instance alert.
Comment 15 pushpesh sharma 2012-09-20 08:00:48 EDT
Created attachment 614862 [details]
alert _icon

Note You need to log in before you can comment on or make changes to this bug.