Bug 800898 - Detached catalogs are getting listed while creating "application blueprint"
Detached catalogs are getting listed while creating "application blueprint"
Status: CLOSED ERRATA
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-conductor (Show other bugs)
1.0.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Angus Thomas
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-07 08:38 EST by Rehana
Modified: 2012-12-04 09:58 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
A user edited catalogs and moved them to any Cloud Resource Zone of any cloud. This bug fix adds in a new feature so that moving catalogs across Cloud Resource Zones is only allowed within the same cloud.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 09:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CRZ (210.66 KB, image/png)
2012-03-07 08:38 EST, Rehana
no flags Details
catalog (205.80 KB, image/png)
2012-03-07 08:39 EST, Rehana
no flags Details
app (222.79 KB, image/png)
2012-03-07 08:39 EST, Rehana
no flags Details

  None (edit)
Description Rehana 2012-03-07 08:38:33 EST
Created attachment 568294 [details]
CRZ

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.build and pushed image to "Default" cloud
2.crated a new catalog "test" pointing to "Default"
3.later change the catalog "test" to a different cloud resource zone(pfa:catalog.png)
4.Tried to create a application blueprint from the image pushed to "default"(app.png)

Actual results:
Observed that the catalog "test" was still getting listed while creating the application blueprint

Expected results:
Should list only the catalogs that are mapped to the cloud to which the image is pushed


Additional info:

[root@intel-d3c69-01 ~]# rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.0-41.el6.noarch
aeolus-configure-2.5.0-18.el6.noarch
aeolus-conductor-daemons-0.8.0-41.el6.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
rubygem-aeolus-cli-0.3.0-13.el6.noarch
aeolus-all-0.8.0-41.el6.noarch
aeolus-conductor-0.8.0-41.el6.noarch
Comment 1 Rehana 2012-03-07 08:39:09 EST
Created attachment 568295 [details]
catalog
Comment 2 Rehana 2012-03-07 08:39:46 EST
Created attachment 568296 [details]
app
Comment 3 Angus Thomas 2012-06-20 13:09:38 EDT
Hi Rehana,

Could you please provide more info, specifically about whether you are using the "default" cloud or cloud resource zone at each stage?


thanks,


Angus
Comment 4 Rehana 2012-06-21 04:36:15 EDT
Now that we cannot edit the Cloud resource zone to point to a different cloud once created, the bug is not reproducable.

Hence closing the bug.

on 

rpm -qa | grep aeolus
aeolus-conductor-doc-0.8.30-1.el6_2.noarch
rubygem-aeolus-cli-0.3.3-2.el6_2.noarch
aeolus-conductor-daemons-0.8.30-1.el6_2.noarch
rubygem-aeolus-image-0.3.0-12.el6.noarch
aeolus-all-0.8.30-1.el6_2.noarch
aeolus-conductor-0.8.30-1.el6_2.noarch
aeolus-configure-2.5.7-2.el6_2.noarch
Comment 6 errata-xmlrpc 2012-12-04 09:58:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1516.html

Note You need to log in before you can comment on or make changes to this bug.