Bug 8010 - margins are wrong on a postscript printer
margins are wrong on a postscript printer
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: rhs-printfilters (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-27 11:25 EST by marchign
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-08 07:24:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description marchign 1999-12-27 11:25:25 EST
I am using a 600x600 dpi ps printer with postscript filter.

Sending directly testpage.ps to /dev/lp0 produces a correct page, giving
the command print ps test page from printtool produces a page shifted up of
approximately one inch.

debug info from filter scripts are the following:
Type of file is INPUT-to-ps
Best path of depth  is cat - | ps-to-printer.fpi
Desired print format is ps
Paper size is a4
A form feed will not be sent.
Magic is |             PostScript document text conforming at level 2.0|
Magic is |             PostScript document text conforming at level 2.0|
Type of file is INPUT-to-ps
Best path of depth  is cat - | ps-to-printer.fpi
Comment 1 Riley H Williams 1999-12-28 13:32:59 EST
Obvious question: What size paper is in the printer?

There have been a few comments recently to the effect that if one has US letter
sized paper in the printer and specify A4 paper size, the text is printed about
1" higher up the page than it ought to be, and I note the following line in your
comments...

 Q> Paper size is a4

...which tends to imply that at least part of that equation is correct.
Comment 2 marchign 1999-12-29 04:58:59 EST
Sorry for lacking detail: paper size is set to A4 and the printer has A4 paper.

So the other half of the equation does not apply ;-)
Comment 3 Bernhard Rosenkraenzer 2000-01-11 09:50:59 EST
I can't reproduce it here. What printer are you using exactly? What does your
/var/spool/lpd/lp0/postscript.cfg say?
Comment 4 marchign 2000-01-14 09:27:59 EST
I am using a TI microlaser 600 and the following is the content of the
postscript.cfg file:
#
# configuration related to postscript printing
# generated automatically by PRINTTOOL
# manual changes to this file may be lost
#
GSDEVICE=POSTSCRIPT
RESOLUTION=600x600
COLOR=
PAPERSIZE=a4
EXTRA_GS_OPTIONS=""
REVERSE_ORDER=
PS_SEND_EOF=NO

#
# following is related to printing multiple pages per output page
#
NUP=1
RTLFTMAR=18
TOPBOTMAR=72
Comment 5 Crutcher Dunnavant 2001-03-15 17:11:24 EST
The new printing system solves this.

Note You need to log in before you can comment on or make changes to this bug.