Bug 801046 - Confusing example of distributed striped volume
Confusing example of distributed striped volume
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: Documentation (Show other bugs)
unspecified
Unspecified Unspecified
low Severity unspecified
: Release Candidate
: RHGS 2.0.0
Assigned To: Divya
shylesh
:
Depends On:
Blocks: 818902 817967
  Show dependency treegraph
 
Reported: 2012-03-07 09:55 EST by b.candler
Modified: 2015-05-13 11:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 818902 (view as bug list)
Environment:
Last Closed: 2015-04-10 03:16:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description b.candler 2012-03-07 09:55:42 EST
In the admin guide (section 5.4) at http://download.gluster.com/pub/gluster/glusterfs/3.2/Documentation/AG/html/sect-Administration_Guide--Setting_Volumes-Distributed_Striped.html

The first example for a "distributed striped volume" is this:

# gluster volume create test-volume stripe 4 transport tcp server1:/exp1 server2:/exp2 server3:/exp3 server4:/exp4

However since there are 4 bricks and a stripe width of 4, this is really just a simple "striped volume" as described previously in section 5.3.

Suggest you drop this example and leave just the second example.
Comment 1 Divya 2012-04-03 07:17:17 EDT
The updated Red Hat Storage 2.0 User Guide is published

http://docs.redhat.com/docs/en-US/Red_Hat_Storage/2/html/User_Guide/sect-User_Guide-Setting_Volumes-Distributed_Striped.html
Comment 3 shishir gowda 2012-05-29 06:44:22 EDT
The doc's have been updated as follows:

# gluster volume create test-volume stripe 4 transport tcp server1:/exp1 server2:/exp2 server3:/exp3 server4:/exp4 server5:/exp5 server6:/exp6 server7:/exp7 server8:/exp8
Creation of test-volume has been successful
Please start the volume to access data.

Note You need to log in before you can comment on or make changes to this bug.